summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-04-27 17:56:54 +0000
committerUlrich Müller <ulm@gentoo.org>2008-04-27 17:56:54 +0000
commit7f8d117751f9d93043e45b8f982eb04acfe240e0 (patch)
tree67f405454d6e141b03333b03f3e6de8224c90f9c /app-emacs
parentMask app-emacs/navi2ch snapshot for testing. (diff)
downloadgentoo-2-7f8d117751f9d93043e45b8f982eb04acfe240e0.tar.gz
gentoo-2-7f8d117751f9d93043e45b8f982eb04acfe240e0.tar.bz2
gentoo-2-7f8d117751f9d93043e45b8f982eb04acfe240e0.zip
Add CVS snapshot, bug 219449.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/navi2ch/ChangeLog10
-rw-r--r--app-emacs/navi2ch/files/50navi2ch-gentoo.el4
-rw-r--r--app-emacs/navi2ch/navi2ch-1.7.5_p20080325.ebuild49
3 files changed, 60 insertions, 3 deletions
diff --git a/app-emacs/navi2ch/ChangeLog b/app-emacs/navi2ch/ChangeLog
index 478e0f96f063..f7b7575fe739 100644
--- a/app-emacs/navi2ch/ChangeLog
+++ b/app-emacs/navi2ch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/navi2ch
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.35 2007/12/25 16:43:02 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.36 2008/04/27 17:56:54 ulm Exp $
+
+*navi2ch-1.7.5_p20080325 (27 Apr 2008)
+
+ 27 Apr 2008; Ulrich Mueller <ulm@gentoo.org> files/50navi2ch-gentoo.el,
+ +navi2ch-1.7.5_p20080325.ebuild:
+ Add CVS snapshot, bug 219449.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing usata from metadata.xml as per #22931.
diff --git a/app-emacs/navi2ch/files/50navi2ch-gentoo.el b/app-emacs/navi2ch/files/50navi2ch-gentoo.el
index 74e842a4aac0..d655be00135f 100644
--- a/app-emacs/navi2ch/files/50navi2ch-gentoo.el
+++ b/app-emacs/navi2ch/files/50navi2ch-gentoo.el
@@ -1,3 +1,5 @@
+
;;; navi2ch site-lisp configuration
-(autoload 'navi2ch "navi2ch" "Navigator for 2ch for Emacs" t)
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'navi2ch "navi2ch" "Navigator for 2ch for Emacs." t)
diff --git a/app-emacs/navi2ch/navi2ch-1.7.5_p20080325.ebuild b/app-emacs/navi2ch/navi2ch-1.7.5_p20080325.ebuild
new file mode 100644
index 000000000000..ed8c8941d083
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.7.5_p20080325.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/navi2ch-1.7.5_p20080325.ebuild,v 1.1 2008/04/27 17:56:54 ulm Exp $
+
+inherit elisp
+
+MY_PV=${PV#*_p}
+DESCRIPTION="A navigator for 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="http://navi2ch.sourceforge.net/snapshot/${PN}-cvs_0.0.${MY_PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+S="${WORKDIR}/${PN}-cvs-${MY_PV}"
+
+src_compile() {
+ econf \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-icondir=${SITEETC}/${PN} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ dodoc ChangeLog* NEWS README TODO
+ newdoc contrib/README README.contrib
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}