summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-04-29 19:01:52 +0000
committerUlrich Müller <ulm@gentoo.org>2012-04-29 19:01:52 +0000
commitac940efcbcc7f00c933d1870288256761ddab962 (patch)
tree1934e542be068e8095e11db1b51b6d76bc46d19f /app-emacs
parentwrong use of scr_unpack scr_prepare fixed (diff)
downloadgentoo-2-ac940efcbcc7f00c933d1870288256761ddab962.tar.gz
gentoo-2-ac940efcbcc7f00c933d1870288256761ddab962.tar.bz2
gentoo-2-ac940efcbcc7f00c933d1870288256761ddab962.zip
Version bump.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cedet/ChangeLog8
-rw-r--r--app-emacs/cedet/cedet-1.1.ebuild80
-rw-r--r--app-emacs/cedet/files/50cedet-gentoo.el3
3 files changed, 89 insertions, 2 deletions
diff --git a/app-emacs/cedet/ChangeLog b/app-emacs/cedet/ChangeLog
index 01d2d8866ef2..b6a8232e7771 100644
--- a/app-emacs/cedet/ChangeLog
+++ b/app-emacs/cedet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/cedet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.73 2012/02/01 17:27:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.74 2012/04/29 19:01:52 ulm Exp $
+
+*cedet-1.1 (29 Apr 2012)
+
+ 29 Apr 2012; Ulrich Müller <ulm@gentoo.org> files/50cedet-gentoo.el,
+ +cedet-1.1.ebuild:
+ Version bump.
01 Feb 2012; Ulrich Müller <ulm@gentoo.org> -cedet-1.0.ebuild:
Remove vulnerable version wrt bug 398227.
diff --git a/app-emacs/cedet/cedet-1.1.ebuild b/app-emacs/cedet/cedet-1.1.ebuild
new file mode 100644
index 000000000000..f533f42e0b60
--- /dev/null
+++ b/app-emacs/cedet/cedet-1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.1.ebuild,v 1.1 2012/04/29 19:01:50 ulm Exp $
+
+EAPI=4
+NEED_EMACS=22
+
+inherit elisp
+
+MY_P=${P/_}
+DESCRIPTION="CEDET: Collection of Emacs Development Environment Tools"
+HOMEPAGE="http://cedet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cedet/${MY_P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+EMACSFLAGS="${EMACSFLAGS} -L ${S}/eieio -L ${S}/semantic -L ${S}/srecode \
+ -L ${S}/ede -L ${S}/speedbar -L ${S}/cogre"
+
+src_compile() {
+ emake -j1 \
+ EMACS="${EMACS}" \
+ EMACSFLAGS="${EMACSFLAGS}"
+}
+
+src_test() {
+ emake -j1 \
+ EMACS="${EMACS}" \
+ EMACSFLAGS="${EMACSFLAGS}" \
+ utest
+}
+
+src_install() {
+ local target file dir
+ find . -type d -name tests -prune -o -type f -print | while read target
+ do
+ file=${target##*/}
+ dir=${target%/*}; dir=${dir#./}
+ case "${file}" in
+ *~ | Makefile | *.texi | *-script | PRERELEASE_CHECKLIST \
+ | Project.ede | USING_CEDET_FROM_BZR | grammar-fw-ov.txt)
+ # ignore
+ ;;
+ ChangeLog | README | AUTHORS | *NEWS | INSTALL \
+ | renamelist.txt | semanticdb.sh)
+ docinto "${dir}"
+ dodoc "${target}" ;;
+ *.el | *.by | *.wy)
+ # install grammar sources along with the elisp files, since
+ # the location where semantic expects them is not configurable
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}" ;;
+ *.elc)
+ # we are in a subshell, so collecting in a variable won't work
+ echo "${target}" >>"${T}/elc-list.txt" ;;
+ *.srt | *.xpm)
+ insinto "${SITEETC}/${PN}/${dir}"
+ doins "${target}" ;;
+ *.info* | grammar-fw-ov.png)
+ doinfo "${target}" ;;
+ *)
+ die "Unrecognised file ${target}" ;;
+ esac
+ done
+
+ # make sure that the compiled elisp files don't have older time stamps
+ # than corresponding sources, in order to suppress warnings at run time
+ while read target; do
+ dir=${target%/*}; dir=${dir#./}
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}"
+ done <"${T}/elc-list.txt"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}
diff --git a/app-emacs/cedet/files/50cedet-gentoo.el b/app-emacs/cedet/files/50cedet-gentoo.el
index 600ad3ba7e96..b11d4ee2c280 100644
--- a/app-emacs/cedet/files/50cedet-gentoo.el
+++ b/app-emacs/cedet/files/50cedet-gentoo.el
@@ -1,7 +1,8 @@
(require 'cedet "@SITELISP@/common/cedet")
(when (boundp 'image-load-path)
(add-to-list 'image-load-path "@SITEETC@/common/icons" t)
- (add-to-list 'image-load-path "@SITEETC@/cogre" t))
+ (add-to-list 'image-load-path "@SITEETC@/cogre" t)
+ (add-to-list 'image-load-path "@SITEETC@/speedbar" t))
(setq srecode-map-load-path
(list "@SITEETC@/srecode/templates"
"@SITEETC@/ede/templates"