summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-04 00:20:42 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-04 00:20:42 +0000
commitd7b734d826170d61bb994519b53f6eb79b1144e4 (patch)
treece1a3cd28fc9acd3169437472fdb0fda263d955e /app-emacs
parentRemove bashism, authorized by scarabeus (diff)
downloadgentoo-2-d7b734d826170d61bb994519b53f6eb79b1144e4.tar.gz
gentoo-2-d7b734d826170d61bb994519b53f6eb79b1144e4.tar.bz2
gentoo-2-d7b734d826170d61bb994519b53f6eb79b1144e4.zip
Install pixmaps under SITEETC instead of SITELISP. Other minor changes.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ecb/ChangeLog15
-rw-r--r--app-emacs/ecb/ecb-2.32-r3.ebuild55
-rw-r--r--app-emacs/ecb/files/ecb-2.32-gentoo.patch73
3 files changed, 140 insertions, 3 deletions
diff --git a/app-emacs/ecb/ChangeLog b/app-emacs/ecb/ChangeLog
index f1b75c06e231..cb94ba59d9e1 100644
--- a/app-emacs/ecb/ChangeLog
+++ b/app-emacs/ecb/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emacs/ecb
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.34 2007/09/24 12:03:55 opfer Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ChangeLog,v 1.35 2009/03/04 00:20:42 ulm Exp $
+
+*ecb-2.32-r3 (03 Mar 2009)
+
+ 03 Mar 2009; Ulrich Mueller <ulm@gentoo.org> +files/ecb-2.32-gentoo.patch,
+ +ecb-2.32-r3.ebuild:
+ Install pixmaps under SITEETC instead of SITELISP. Use proper patch for
+ help and info paths, instead of sed tweaks. Allow any compress extension
+ of Info files; don't hardcode .gz. Add alternative load-path for jde, in
+ order to prepare for a later change of its install location.
24 Sep 2007; Christian Faulhammer <opfer@gentoo.org>
-files/70ecb-gentoo.el, -ecb-2.32-r1.ebuild:
@@ -85,7 +94,7 @@
eieio and semantic; bug #64395.
27 Aug 2004; Jared Hudson <jhhudso@gentoo.org> : Added ~amd64 keyword
-
+
01 Jun 2004; Aron Griffis <agriffis@gentoo.org> ecb-2.21.ebuild,
ecb-2.24.ebuild:
Fix use invocation
diff --git a/app-emacs/ecb/ecb-2.32-r3.ebuild b/app-emacs/ecb/ecb-2.32-r3.ebuild
new file mode 100644
index 000000000000..a46bc808819a
--- /dev/null
+++ b/app-emacs/ecb/ecb-2.32-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-2.32-r3.ebuild,v 1.1 2009/03/04 00:20:42 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Source code browser for Emacs"
+HOMEPAGE="http://ecb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ecb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="java"
+
+DEPEND="app-emacs/cedet
+ java? ( app-emacs/jde )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="71${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ sed -i -e "s:@PF@:${PF}:" ecb-help.el || die "sed failed"
+}
+
+src_compile() {
+ local loadpath=""
+ if use java; then
+ loadpath="${SITELISP}/elib ${SITELISP}/jde ${SITELISP}/jde/lisp"
+ fi
+
+ emake CEDET="${SITELISP}/cedet" LOADPATH="${loadpath}" \
+ || die "emake failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r ecb-images || die
+
+ doinfo info-help/ecb.info* || die
+ dohtml html-help/*.html || die
+ dodoc NEWS README RELEASE_NOTES || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "ECB is now autoloaded in site-gentoo.el. Add the line"
+ elog " (require 'ecb)"
+ elog "to your ~/.emacs file to enable all features on Emacs startup."
+}
diff --git a/app-emacs/ecb/files/ecb-2.32-gentoo.patch b/app-emacs/ecb/files/ecb-2.32-gentoo.patch
new file mode 100644
index 000000000000..09d3d86afdcd
--- /dev/null
+++ b/app-emacs/ecb/files/ecb-2.32-gentoo.patch
@@ -0,0 +1,73 @@
+Change default paths to Gentoo install locations.
+Allow for compressed Info files.
+
+--- ecb-2.32-orig/ecb-common-browser.el 2005-07-11 16:16:01.000000000 +0200
++++ ecb-2.32/ecb-common-browser.el 2009-03-03 09:42:51.000000000 +0100
+@@ -261,10 +261,7 @@
+ ;; additonal images are necessary - but currently i don't think we need
+ ;; special images for this analyse-stuff.
+ (defcustom ecb-tree-image-icons-directories
+- (let ((base (concat (if ecb-regular-xemacs-package-p
+- (format "%s" (locate-data-directory "ecb"))
+- ecb-ecb-dir)
+- "ecb-images/")))
++ (let ((base "/usr/share/emacs/etc/ecb/ecb-images/"))
+ (cons (concat base "default/height-17")
+ (mapcar (function (lambda (i)
+ (cons (car i) (concat base (cdr i)))))
+--- ecb-2.32-orig/ecb-help.el 2005-07-11 16:16:00.000000000 +0200
++++ ecb-2.32/ecb-help.el 2009-03-03 09:47:49.000000000 +0100
+@@ -81,16 +81,8 @@
+ (const :tag "Html" :value html)))
+
+
+-(defcustom ecb-help-info-path (concat
+- (if ecb-running-xemacs
+- (if (file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-info-subdir
+- ecb-help-info-start-file))
+- ecb-help-info-subdir
+- "../../info/")
+- ecb-help-info-subdir)
+- ecb-help-info-start-file)
++(defcustom ecb-help-info-path
++ (concat "/usr/share/info/" ecb-help-info-start-file)
+ "*Path where the ECB online help in info format resides.
+ This must be the location of the file \"ecb.info\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB
+@@ -107,24 +99,7 @@
+ :type 'file)
+
+ (defcustom ecb-help-html-path
+- (if (not ecb-running-xemacs)
+- (concat ecb-help-html-subdir ecb-help-html-start-file)
+- (cond ((file-exists-p
+- (concat ecb-ecb-dir
+- ecb-help-html-subdir
+- ecb-help-html-start-file))
+- (concat ecb-help-html-subdir ecb-help-html-start-file))
+- ((file-exists-p
+- (concat ecb-ecb-dir
+- "../../html/"
+- ecb-help-html-start-file))
+- (concat "../../html/" ecb-help-html-start-file))
+- ((file-exists-p
+- (concat ecb-ecb-dir
+- "../../html/ecb/index.html"))
+- "../../html/ecb/index.html")
+- (t
+- (concat "../../etc/ecb/html/" ecb-help-html-start-file))))
++ (concat "/usr/share/doc/@PF@/html/" ecb-help-html-start-file)
+ "*Path where the ECB online help in HTML format resides.
+ This must be the location of the file \"index.html\" which comes with the ECB
+ distribution. If is installed by unpacking the archive available on the ECB
+@@ -145,7 +120,7 @@
+ "Starts `info' with INFO-FILE. If INFO-FILE does not exists then nil is
+ returned otherwise true. If NO-FILE-NOT-EXIST-ERR is not nil then just nil is
+ returned if INFO-FILE does not exist otherwise an error is reported."
+- (if (file-exists-p info-file)
++ (if (file-expand-wildcards (concat info-file "*"))
+ (prog1 t
+ (info info-file))
+ (unless no-file-not-exist-err