summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-07-09 18:15:44 +0000
committerUlrich Müller <ulm@gentoo.org>2010-07-09 18:15:44 +0000
commite4a2ab7b482192b7f6cf91b351b9b64c6933f0c6 (patch)
tree899bb2aa39c07ffd54831e60d1a61165bc750172 /app-emacs
parentdigest fix (diff)
downloadgentoo-2-e4a2ab7b482192b7f6cf91b351b9b64c6933f0c6.tar.gz
gentoo-2-e4a2ab7b482192b7f6cf91b351b9b64c6933f0c6.tar.bz2
gentoo-2-e4a2ab7b482192b7f6cf91b351b9b64c6933f0c6.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gentoo-syntax/ChangeLog8
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-1.17.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/app-emacs/gentoo-syntax/ChangeLog b/app-emacs/gentoo-syntax/ChangeLog
index b621e4c68b4f..620fc0887e44 100644
--- a/app-emacs/gentoo-syntax/ChangeLog
+++ b/app-emacs/gentoo-syntax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/gentoo-syntax
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.67 2010/05/22 08:06:15 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.68 2010/07/09 18:15:44 ulm Exp $
+
+*gentoo-syntax-1.17 (09 Jul 2010)
+
+ 09 Jul 2010; Ulrich Mueller <ulm@gentoo.org> +gentoo-syntax-1.17.ebuild:
+ Version bump. Many font-lock keywords for eclasses have been added.
+ List of architectures is now initialised from profiles.desc, bug 304133.
22 May 2010; Ulrich Mueller <ulm@gentoo.org> -gentoo-syntax-1.12.ebuild,
-files/50gentoo-syntax-gentoo-1.12.el, -gentoo-syntax-1.15-r1.ebuild:
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-1.17.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-1.17.ebuild
new file mode 100644
index 000000000000..f41e40ef1723
--- /dev/null
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-1.17.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.17.ebuild,v 1.1 2010/07/09 18:15:44 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DOCS="ChangeLog"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ makeinfo gentoo-syntax.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ sed -e "s:@PORTDIR@:${PORTDIR}:" \
+ "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo gentoo-syntax.info || die
+ dodoc ${DOCS} || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Some optional features may require installation of additional"
+ elog "packages, like app-portage/gentoolkit-dev for echangelog."
+}