summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-11-07 20:46:42 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-11-07 20:46:42 +0000
commitaee4fe12c5aaa55a1b6a12d8e31a459661ddc7e7 (patch)
treedce9a3b6855c52dc13781f0081f8871bd0f604c5 /app-emulation/bochs
parentfixed compilation time error and marked ~amd64. depends on glibc now (Manifes... (diff)
downloadgentoo-2-aee4fe12c5aaa55a1b6a12d8e31a459661ddc7e7.tar.gz
gentoo-2-aee4fe12c5aaa55a1b6a12d8e31a459661ddc7e7.tar.bz2
gentoo-2-aee4fe12c5aaa55a1b6a12d8e31a459661ddc7e7.zip
x86 and ppc stable
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog6
-rw-r--r--app-emulation/bochs/bochs-2.0.2.ebuild55
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild4
3 files changed, 38 insertions, 27 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index b474a2f65fba..91ce0d4cc349 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.29 2004/10/24 13:26:25 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.30 2004/11/07 20:46:42 lu_zero Exp $
+
+ 07 Nov 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.0.2.ebuild,
+ bochs-2.1.1.ebuild:
+ Marked stable for ppc and x86
24 Oct 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.1.1.ebuild:
Added debugger useflag, should address the bug #25227
diff --git a/app-emulation/bochs/bochs-2.0.2.ebuild b/app-emulation/bochs/bochs-2.0.2.ebuild
index fca3b9fa0370..4b0675c592ba 100644
--- a/app-emulation/bochs/bochs-2.0.2.ebuild
+++ b/app-emulation/bochs/bochs-2.0.2.ebuild
@@ -1,29 +1,30 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.16 2004/10/31 05:04:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.17 2004/11/07 20:46:42 lu_zero Exp $
-inherit eutils
+inherit eutils wxwidgets
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ~ppc alpha sparc"
-IUSE="sdl gtk"
+KEYWORDS="x86 ppc alpha sparc"
+IUSE="sdl wxwindows readline gtk2 debugger"
RDEPEND="virtual/libc
virtual/x11
sdl? ( media-libs/libsdl )
- gtk? ( x11-libs/wxGTK )"
+ wxwindows? ( x11-libs/wxGTK )
+ readline? sys-libs/readline"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_unpack() {
- unpack ${A}
-# unpack ${P}.tar.gz
+# unpack ${A}
+ unpack ${P}.tar.gz
cd ${S}
# -e 's:MAN_PAGE_1_LIST=bochs bximage bochs-dlx:MAN_PAGE_1_LIST=bochs bximage:'
sed -i \
@@ -31,16 +32,34 @@ src_unpack() {
-e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
-e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
die "sed Makefile.in failed"
- epatch ${FILESDIR}/${P}-gcc3.patch || die
+# epatch ${FILESDIR}/${P}-gcc3.patch || die
}
src_compile() {
- [ "$ARCH" == "x86" ] && myconf="--enable-idle-hack"
+ if ! use gtk2 ; then
+ need-wxwidgets gtk
+ else
+ need-wxwidgets gtk2
+ fi
+ [ "$ARCH" == "x86" ] \
+ && myconf="--enable-idle-hack --enable-fast-function-calls"
myconf="${myconf} `use_with sdl`"
- myconf="${myconf} `use_with gtk wx`"
+ myconf="${myconf} `use_enable readline`"
+ use wxwindows && \
+ myconf="${myconf} --with-gtk --with-wx"
+ use wxwindows || \
+ myconf="${myconf} --without-gtk --without-wx"
+ use bochs-debugger && \
+ myconf="$myconf --enable-debugger --enable-disasm
+ --enable-x86-debugger"
./configure \
--enable-fpu --enable-cdrom --enable-control-panel \
+ --enable-usb --enable-pci --enable-mmx --enable-sse\
+ --enable-cpu-level=6 \
+ --enable-repeat-speedups --enable-guest2host-tlb \
+ --enable-plugins --enable-debugger \
+ --enable-ignore-bad-msr \
--enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
--infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} \
--with-x11 $myconf || \
@@ -53,18 +72,6 @@ src_install() {
make DESTDIR=${D} install unpack_dlx || die "make install failed"
#workaround
make prefix=${D}/usr install_dlx
- #cleanup
- rm -rf ${D}/usr/share/bochs/{vga.pcf,install-x11-fonts,test-x11-fonts}
- rm -rf ${D}/usr/share/bochs/keymaps/CVS
- insinto /usr/X11R6/lib/X11/fonts/misc
- doins ${S}/font/vga.pcf
- gzip ${D}/usr/X11R6/lib/X11/fonts/misc/vga.pcf
- dodoc CHANGES CVS README TESTFORM.txt || die "dodoc failed"
-}
-pkg_postinst() {
- einfo "Updating the font index"
- mkfontdir /usr/X11R6/lib/X11/fonts/misc
- einfo "If you are running X please update the fontlist with:"
- einfo "# xset fp rehash"
+ dodoc CHANGES README TESTFORM.txt || die "dodoc failed"
}
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index d20f774c949e..a604c7c04abf 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.11 2004/10/31 05:04:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.12 2004/11/07 20:46:42 lu_zero Exp $
inherit eutils wxwidgets
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
+KEYWORDS="x86 ppc alpha ~sparc ~amd64"
IUSE="sdl wxwindows readline gtk2 debugger"
RDEPEND="virtual/libc