summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-15 19:09:22 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-15 19:09:22 +0000
commitac7c87394d5eeef6f7670c03fcc92114a4e238e0 (patch)
tree3a04c7621a06c472e3bdb1509c77d201b6f61c4d /app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild
parentSvn snapshot (exported on 060114) bump. Added maintainer and longdescription ... (diff)
downloadgentoo-2-ac7c87394d5eeef6f7670c03fcc92114a4e238e0.tar.gz
gentoo-2-ac7c87394d5eeef6f7670c03fcc92114a4e238e0.tar.bz2
gentoo-2-ac7c87394d5eeef6f7670c03fcc92114a4e238e0.zip
Version bump for security #118101.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild')
-rw-r--r--app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild
new file mode 100644
index 000000000000..fbe83833dce8
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-5.0.1.ebuild,v 1.1 2006/01/15 19:09:22 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="specialized version of wine for MS Office"
+HOMEPAGE="http://www.codeweavers.com/site/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="nas"
+RESTRICT="fetch nostrip"
+
+RDEPEND="virtual/x11
+ nas? ( media-libs/nas )
+ sys-libs/glibc
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}