summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-13 12:21:33 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-13 12:21:33 +0000
commit81f5ee58caeb709c6b00e3f819b69cd8d6808976 (patch)
treeddd2b6b90001b3d950e2f373aea4baba8ce0a7db /app-emulation/dinero
parentMarked ppc stable for bug #318881. (diff)
downloadgentoo-2-81f5ee58caeb709c6b00e3f819b69cd8d6808976.tar.gz
gentoo-2-81f5ee58caeb709c6b00e3f819b69cd8d6808976.tar.bz2
gentoo-2-81f5ee58caeb709c6b00e3f819b69cd8d6808976.zip
Respect LDFLAGS wrt bug 331837. Thanks to Diego for report.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/dinero')
-rw-r--r--app-emulation/dinero/ChangeLog7
-rw-r--r--app-emulation/dinero/dinero-4.7.ebuild11
2 files changed, 14 insertions, 4 deletions
diff --git a/app-emulation/dinero/ChangeLog b/app-emulation/dinero/ChangeLog
index d2b96a32dd74..963559b59d10 100644
--- a/app-emulation/dinero/ChangeLog
+++ b/app-emulation/dinero/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/dinero
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dinero/ChangeLog,v 1.10 2008/12/30 18:53:51 angelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dinero/ChangeLog,v 1.11 2010/08/13 12:21:33 xarthisius Exp $
+
+ 13 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org> dinero-4.7.ebuild:
+ Respect LDFLAGS wrt bug 331837. Thanks to Diego for report.
30 Dec 2008; Christoph Mende <angelos@gentoo.org> dinero-4.7.ebuild:
QA: Respect AR/CC/RANLIB (bug 243576)
diff --git a/app-emulation/dinero/dinero-4.7.ebuild b/app-emulation/dinero/dinero-4.7.ebuild
index 792cfdf40a8c..e5e194cdc4c1 100644
--- a/app-emulation/dinero/dinero-4.7.ebuild
+++ b/app-emulation/dinero/dinero-4.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dinero/dinero-4.7.ebuild,v 1.9 2008/12/30 18:53:51 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dinero/dinero-4.7.ebuild,v 1.10 2010/08/13 12:21:33 xarthisius Exp $
inherit toolchain-funcs
@@ -15,6 +15,13 @@ KEYWORDS="x86 ppc"
LICENSE="as-is"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/\$(CC)/& \$(LDFLAGS)/" \
+ -i Makefile.in || die #331837
+}
+
src_compile() {
tc-export AR CC RANLIB
econf