summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-01-31 16:49:42 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-01-31 16:49:42 +0000
commitff29b663a59faf50f7916d457d4324d7b6eb74c7 (patch)
tree227e0c0ec7c8bc8256cca39032d966f47356dd95 /app-emulation/docker-compose
parentadd ~x64-macos, bug 535970 (diff)
downloadgentoo-2-ff29b663a59faf50f7916d457d4324d7b6eb74c7.tar.gz
gentoo-2-ff29b663a59faf50f7916d457d4324d7b6eb74c7.tar.bz2
gentoo-2-ff29b663a59faf50f7916d457d4324d7b6eb74c7.zip
add ebuild for docker-compose (the software formerly known as fig)
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/ChangeLog11
-rw-r--r--app-emulation/docker-compose/docker-compose-1.1.0_rc1.ebuild51
-rw-r--r--app-emulation/docker-compose/docker-compose-1.1.0_rc2.ebuild51
-rw-r--r--app-emulation/docker-compose/metadata.xml10
4 files changed, 123 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/ChangeLog b/app-emulation/docker-compose/ChangeLog
new file mode 100644
index 000000000000..e999449cb9f0
--- /dev/null
+++ b/app-emulation/docker-compose/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emulation/docker-compose
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker-compose/ChangeLog,v 1.1 2015/01/31 16:49:42 alunduil Exp $
+
+*docker-compose-1.1.0_rc2 (31 Jan 2015)
+*docker-compose-1.1.0_rc1 (31 Jan 2015)
+
+ 31 Jan 2015; Alex Brandt <alunduil@gentoo.org>
+ +docker-compose-1.1.0_rc1.ebuild, +docker-compose-1.1.0_rc2.ebuild,
+ +metadata.xml:
+ add ebuild for docker-compose (the software formerly known as fig)
diff --git a/app-emulation/docker-compose/docker-compose-1.1.0_rc1.ebuild b/app-emulation/docker-compose/docker-compose-1.1.0_rc1.ebuild
new file mode 100644
index 000000000000..be9bb1e8ec1b
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.1.0_rc1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker-compose/docker-compose-1.1.0_rc1.ebuild,v 1.1 2015/01/31 16:49:42 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV="${PV//_/-}"
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/docker/fig/archive/${MY_PV}.tar.gz -> ${P}.tar.gz" # still called fig on github
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/dockerpty-0.3.2[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.4[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/docker-py-0.7[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.11.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-0.12[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests tests/unit || die "Tests failed under ${EPYTHON}"
+}
diff --git a/app-emulation/docker-compose/docker-compose-1.1.0_rc2.ebuild b/app-emulation/docker-compose/docker-compose-1.1.0_rc2.ebuild
new file mode 100644
index 000000000000..c6362358586a
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.1.0_rc2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker-compose/docker-compose-1.1.0_rc2.ebuild,v 1.1 2015/01/31 16:49:42 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV="${PV//_/-}"
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/dockerpty-0.3.2[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.4[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/docker-py-0.8[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.11.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests tests/unit || die "Tests failed under ${EPYTHON}"
+}
diff --git a/app-emulation/docker-compose/metadata.xml b/app-emulation/docker-compose/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/app-emulation/docker-compose/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>