summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-07 17:56:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-07 17:56:06 +0000
commit771cdc6e9deff81922e43e9671875f2394a924c4 (patch)
tree021bd3d46235d0904f2978a4c2130c0bd65d0015 /app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild
parentkwin-4.8 needs at least some opengl to build, bug 402029 (diff)
downloadgentoo-2-771cdc6e9deff81922e43e9671875f2394a924c4.tar.gz
gentoo-2-771cdc6e9deff81922e43e9671875f2394a924c4.tar.bz2
gentoo-2-771cdc6e9deff81922e43e9671875f2394a924c4.zip
Fixed USE=test to use QuickCheck-1.* (fixes bug #316629 by Diego Elio Pettenò and others). Added package to haskell herd as well.
(Portage version: 2.2.0_alpha89_p3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild')
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild
index 792bc8b5a336..3fbf21065f05 100644
--- a/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild,v 1.3 2011/03/07 19:00:05 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.2.8.ebuild,v 1.4 2012/03/07 17:56:06 slyfox Exp $
EAPI="2"
-inherit multilib
+inherit eutils multilib
DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
clusters."
@@ -14,7 +14,7 @@ SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc"
+IUSE="doc test"
DEPEND="dev-lang/ghc
dev-haskell/json
@@ -22,11 +22,13 @@ DEPEND="dev-lang/ghc
dev-haskell/network"
RDEPEND="${DEPEND}
!>=app-emulation/ganeti-2.4"
+DEPEND+=" test? ( dev-haskell/quickcheck:1 )"
src_prepare() {
# htools does not currently compile cleanly with ghc-6.12+, so remove this
# for now
sed -i -e "s:-Werror ::" Makefile
+ epatch "${FILESDIR}"/${P}-use-QC-1.patch #316629
}
src_compile() {