summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-18 20:55:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-18 20:55:25 +0000
commitdddcdcced7e9f1288e79b1a51ea437f56b25ec1b (patch)
tree1c69d0b93b27954f56c36e91a1a37cf4aac22781 /app-emulation/kqemu
parentremoved old (diff)
downloadgentoo-2-dddcdcced7e9f1288e79b1a51ea437f56b25ec1b.tar.gz
gentoo-2-dddcdcced7e9f1288e79b1a51ea437f56b25ec1b.tar.bz2
gentoo-2-dddcdcced7e9f1288e79b1a51ea437f56b25ec1b.zip
Non-maintainer commit. Apply patch to build against 2.6.37. Thanks to Alexandre Rostovtsev <tetromino@gmail.com>. Bug #350746
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/kqemu')
-rw-r--r--app-emulation/kqemu/ChangeLog9
-rw-r--r--app-emulation/kqemu/files/kqemu-1.4.0_pre1-init_MUTEX.patch16
-rw-r--r--app-emulation/kqemu/kqemu-1.4.0_pre1-r1.ebuild5
3 files changed, 26 insertions, 4 deletions
diff --git a/app-emulation/kqemu/ChangeLog b/app-emulation/kqemu/ChangeLog
index e213674f69cd..c49cb5986e39 100644
--- a/app-emulation/kqemu/ChangeLog
+++ b/app-emulation/kqemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/kqemu
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.29 2009/11/20 13:15:10 zzam Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.30 2011/01/18 20:55:25 hwoarang Exp $
+
+ 18 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
+ kqemu-1.4.0_pre1-r1.ebuild, +files/kqemu-1.4.0_pre1-init_MUTEX.patch:
+ Non-maintainer commit. Apply patch to build against 2.6.37. Thanks to
+ Alexandre Rostovtsev <tetromino@gmail.com>. Bug #350746
*kqemu-1.4.0_pre1-r1 (20 Nov 2009)
diff --git a/app-emulation/kqemu/files/kqemu-1.4.0_pre1-init_MUTEX.patch b/app-emulation/kqemu/files/kqemu-1.4.0_pre1-init_MUTEX.patch
new file mode 100644
index 000000000000..0827e724feaf
--- /dev/null
+++ b/app-emulation/kqemu/files/kqemu-1.4.0_pre1-init_MUTEX.patch
@@ -0,0 +1,16 @@
+Common subdirectories: kqemu-1.4.0pre1-orig/common and kqemu-1.4.0pre1/common
+diff -u kqemu-1.4.0pre1-orig/kqemu-linux.c kqemu-1.4.0pre1/kqemu-linux.c
+--- kqemu-1.4.0pre1-orig/kqemu-linux.c 2008-05-30 16:33:34.000000000 -0400
++++ kqemu-1.4.0pre1/kqemu-linux.c 2011-01-05 16:51:45.407394748 -0500
+@@ -53,6 +53,10 @@
+ #define PAGE_KERNEL_EXEC PAGE_KERNEL
+ #endif
+
++/* init_MUTEX macro was removed in 2.6.37 */
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2, 6, 36) && !defined(init_MUTEX)
++#define init_MUTEX(sem) sema_init(sem, 1)
++#endif
+ //#define DEBUG
+
+ #ifdef DEBUG
+Common subdirectories: kqemu-1.4.0pre1-orig/tests and kqemu-1.4.0pre1/tests
diff --git a/app-emulation/kqemu/kqemu-1.4.0_pre1-r1.ebuild b/app-emulation/kqemu/kqemu-1.4.0_pre1-r1.ebuild
index f201bf03a739..4f8b28141765 100644
--- a/app-emulation/kqemu/kqemu-1.4.0_pre1-r1.ebuild
+++ b/app-emulation/kqemu/kqemu-1.4.0_pre1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.4.0_pre1-r1.ebuild,v 1.1 2009/11/20 13:15:10 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.4.0_pre1-r1.ebuild,v 1.2 2011/01/18 20:55:25 hwoarang Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -41,6 +41,7 @@ src_unpack() {
-e 's/^CFLAGS=\(.*\)/CFLAGS+=\1/' \
-i common/Makefile
epatch "${FILESDIR}/${P}-missing-sched-header.patch"
+ epatch "${FILESDIR}"/${P}-init_MUTEX.patch
}
src_compile() {