summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-09-11 05:14:53 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-09-11 05:14:53 +0000
commit227bd1fa58a10cbf4f662ab2b7da65d0098ea9c3 (patch)
tree5d45fbb39e728f7fe4cbc1199173adba55b660cf /app-emulation/mips64emul/mips64emul-0.2.ebuild
parentFixed xargs again. (Manifest recommit) (diff)
downloadgentoo-2-227bd1fa58a10cbf4f662ab2b7da65d0098ea9c3.tar.gz
gentoo-2-227bd1fa58a10cbf4f662ab2b7da65d0098ea9c3.tar.bz2
gentoo-2-227bd1fa58a10cbf4f662ab2b7da65d0098ea9c3.zip
Rev updates. Removed 0.2_pre, replace with real 0.2, and added 0.3_pre (20040905 snap).
Diffstat (limited to 'app-emulation/mips64emul/mips64emul-0.2.ebuild')
-rw-r--r--app-emulation/mips64emul/mips64emul-0.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/mips64emul/mips64emul-0.2.ebuild b/app-emulation/mips64emul/mips64emul-0.2.ebuild
new file mode 100644
index 000000000000..afe35880c6c7
--- /dev/null
+++ b/app-emulation/mips64emul/mips64emul-0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mips64emul/mips64emul-0.2.ebuild,v 1.1 2004/09/11 05:14:53 kumba Exp $
+
+DESCRIPTION="MIPS Machine Emulator, Emulates many machines/CPUs/OSes"
+HOMEPAGE="http://www.mdstud.chalmers.se/~md1gavan/${PN}/index.html"
+SRC_URI="http://www.mdstud.chalmers.se/~md1gavan/${PN}/src/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 sparc ~mips"
+IUSE="X cacheemu delays mips16"
+#IUSE="X cacheemu delays mips16 userland"
+DEPEND="X? ( virtual/x11 )"
+RDEPEND=""
+
+
+src_compile() {
+ cd ${S}
+
+ # See what configure options to pass
+ local myconf
+ use ! X && myconf="${myconf} --nox11"
+ use cacheemu && myconf="${myconf} --caches"
+ use delays && myconf="${myconf} --delays"
+ use mips16 && myconf="${myconf} --mips16"
+# use userland && myconf="${myconf} --userland" # Not implemented yet, in 0.3
+
+ # Run configure
+ einfo "Passing the following flags to configure: ${myconf}"
+ echo -e ""
+ ./configure ${myconf}
+ echo -e ""
+
+ # Build
+ emake
+}
+
+src_install() {
+ cd ${S}
+ dodoc BUGS HISTORY LICENSE README RELEASE TODO doc/index.html doc/technical.html
+ doman doc/mips64emul.1
+ dobin mips64emul
+}