summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-02-26 06:49:06 +0000
committerMark Guertin <gerk@gentoo.org>2003-02-26 06:49:06 +0000
commit5c09b920e686e7f8cb101d3b3422d0779cd61a4a (patch)
tree84ac22460d2279c1ddd03d4415f1ed10f7101886 /app-emulation/mol
parentVersion bump for orinoco drivers (diff)
downloadgentoo-2-5c09b920e686e7f8cb101d3b3422d0779cd61a4a.tar.gz
gentoo-2-5c09b920e686e7f8cb101d3b3422d0779cd61a4a.tar.bz2
gentoo-2-5c09b920e686e7f8cb101d3b3422d0779cd61a4a.zip
new ebuild
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog8
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.68-r21
-rw-r--r--app-emulation/mol/mol-0.9.68-r2.ebuild49
3 files changed, 57 insertions, 1 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 21a4dd880933..be215494c4fe 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.12 2003/02/12 04:01:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.13 2003/02/26 06:49:06 gerk Exp $
+
+*mol-0.9.68-r2 (26 Feb 2003)
+
+ 26 Feb 2003; Mark Guertin <gerk@gentoo.org> mol-0.9.68-r2.ebuild files/digest-mol-0.9.68-r2 :
+ New build. Compatible with OSX 10.2.4, updated audio and ethernet drivers,
+ ejectable cdroms and more. Thanks to Lars Weiler for the build and testing.
*mol-0.9.68 (06 Feb 2003)
06 Feb 2003; Mark Guertin <gerk@gentoo.org> mol-0.9.68.ebuild :
diff --git a/app-emulation/mol/files/digest-mol-0.9.68-r2 b/app-emulation/mol/files/digest-mol-0.9.68-r2
new file mode 100644
index 000000000000..88ef24fe5255
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.68-r2
@@ -0,0 +1 @@
+MD5 36e549ce159b06c217ed2c2ea441ac2d mol-0.9.68-r2.tar.bz2 1384262
diff --git a/app-emulation/mol/mol-0.9.68-r2.ebuild b/app-emulation/mol/mol-0.9.68-r2.ebuild
new file mode 100644
index 000000000000..30fcd07e5c4a
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.68-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.68-r2.ebuild,v 1.1 2003/02/26 06:49:06 gerk Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}-${PR}
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS under Linux"
+SRC_URI="http://cvs.gentoo.org/~gerk/distfiles/${P}-${PR}.tar.bz2"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND=""
+RDEPEND="net-misc/dhcp
+ sys-apps/iptables"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="ppc -x86 -sparc -alpha -mips"
+IUSE=""
+
+src_compile() {
+
+ filter-flags -fsigned-char
+
+ # dhcp config fix
+ cd ${S}
+ sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
+
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ emake || die "Failed to compile MOL"
+
+}
+
+src_install() {
+
+ emake DESTDIR=${D} install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol"
+ einfo "You might want to configure video modes first with molvconfig"
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ einfo "For networking and sound you might install the Drivers in the"
+ einfo "folder \"MOL-Install\" on your Mac OS X-Desktop."
+}