summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-17 17:55:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-17 17:55:01 +0000
commit57b88a382f44f2a430fb59e9a86fe1f1683f357d (patch)
treeb25fea33d4c9bfe5542c4bda6029d687903c2c8e /app-emulation/uae
parentNew ncurses ebuild. Please comment on bug #9245 (diff)
downloadgentoo-2-57b88a382f44f2a430fb59e9a86fe1f1683f357d.tar.gz
gentoo-2-57b88a382f44f2a430fb59e9a86fe1f1683f357d.tar.bz2
gentoo-2-57b88a382f44f2a430fb59e9a86fe1f1683f357d.zip
emake->make
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/ChangeLog7
-rw-r--r--app-emulation/uae/uae-0.8.22.ebuild28
2 files changed, 19 insertions, 16 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 19272f70e063..619106771f41 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-emulation/uae
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.3 2002/10/17 13:45:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.4 2002/10/17 17:55:01 seemant Exp $
*uae-0.8.22 (9 Oct 2002)
+ 17 Oct 2002; Seemant Kulleen <seemant@gentoo.org> uae-0.8.22.ebuild :
+
+ emake->make. Closes bug #8968 by klausman-usenet@tuts.net (Tobias
+ Klausmann)
+
17 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> uae-0.8.22.ebuild :
Added IUSE.
diff --git a/app-emulation/uae/uae-0.8.22.ebuild b/app-emulation/uae/uae-0.8.22.ebuild
index 9cedcd3973eb..7484745fc33a 100644
--- a/app-emulation/uae/uae-0.8.22.ebuild
+++ b/app-emulation/uae/uae-0.8.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.22.ebuild,v 1.4 2002/10/17 13:45:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.22.ebuild,v 1.5 2002/10/17 17:55:01 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="An amiga emulator"
@@ -14,31 +14,29 @@ KEYWORDS="x86"
IUSE="X gtk svga sdl"
src_compile() {
- local myopt
- myopt="";
+ local myconf
+ myconf="";
if [ `use X` ]; then
- myopt="--with-x --enable-dga --enable-vidmode --with-sdl --with-sdl-sound --with-sdl-gfx"
+ myconf="--with-x --enable-dga --enable-vidmode --with-sdl --with-sdl-sound --with-sdl-gfx"
- use gtk && myopt="$myopt --enable-ui"
- use gtk || myopt="$myopt --disable-ui"
+ use gtk && myconf="$myconf --enable-ui"
+ use gtk || myconf="$myconf --disable-ui"
else
if [ `use svga` ]; then
- myopt="--with-svgalib";
+ myconf="--with-svgalib";
else
- myopt="--with-asciiart";
+ myconf="--with-asciiart";
fi
fi
patch -p0 < ${FILESDIR}/uae-patch.diff
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --enable-threads \
- --enable-scsi-device \
- ${myopt} || die "./configure failed"
+ econf \
+ --enable-threads \
+ --enable-scsi-device \
+ ${myconf} || die "./configure failed"
- emake || die
+ make || die
}
src_install() {