summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-02-02 21:58:31 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-02-02 21:58:31 +0000
commitcc9c8bbbae119adbd7683d824faa7bf467d6f9d8 (patch)
treeed3ec77815216d3b495de5e31891210ef3cac8c0 /app-emulation/virtinst/virtinst-0.500.5.ebuild
parentfixed svrpport used up from vdr-1.7.15 (diff)
downloadgentoo-2-cc9c8bbbae119adbd7683d824faa7bf467d6f9d8.tar.gz
gentoo-2-cc9c8bbbae119adbd7683d824faa7bf467d6f9d8.tar.bz2
gentoo-2-cc9c8bbbae119adbd7683d824faa7bf467d6f9d8.zip
Version bump to support CPU model/features, support graphics (vnc, sdl, spice) configs, and support skipping the install and just dumping the XML. Additionally added a missing depend on libxml2.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virtinst/virtinst-0.500.5.ebuild')
-rw-r--r--app-emulation/virtinst/virtinst-0.500.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/virtinst/virtinst-0.500.5.ebuild b/app-emulation/virtinst/virtinst-0.500.5.ebuild
new file mode 100644
index 000000000000..8f0a70d3abc8
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.500.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.5.ebuild,v 1.1 2011/02/02 21:58:31 cardoe Exp $
+
+#BACKPORTS=1
+
+EAPI=3
+
+if [[ ${PV} = *9999* ]]; then
+ EHG_REPO_URI="http://hg.fedorahosted.org/hg/python-virtinst"
+ HG_ECLASS="mercurial autotools"
+fi
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils ${HG_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}