summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-06-06 14:39:45 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-06-06 14:39:45 +0000
commit9821f0672defda653d8f37dfe4e867d0072d975b (patch)
tree3ba7d156de3e83d6f378a8c349f9ac6057d66043 /app-emulation/virtualbox
parentVersion bump. Bug # 180323. (diff)
downloadgentoo-2-9821f0672defda653d8f37dfe4e867d0072d975b.tar.gz
gentoo-2-9821f0672defda653d8f37dfe4e867d0072d975b.tar.bz2
gentoo-2-9821f0672defda653d8f37dfe4e867d0072d975b.zip
Version bump, thanks to Alessio
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-emulation/virtualbox')
-rw-r--r--app-emulation/virtualbox/ChangeLog7
-rw-r--r--app-emulation/virtualbox/files/digest-virtualbox-1.4.03
-rw-r--r--app-emulation/virtualbox/virtualbox-1.4.0.ebuild143
3 files changed, 152 insertions, 1 deletions
diff --git a/app-emulation/virtualbox/ChangeLog b/app-emulation/virtualbox/ChangeLog
index 490dbbcb03c5..1cba7ec68aeb 100644
--- a/app-emulation/virtualbox/ChangeLog
+++ b/app-emulation/virtualbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virtualbox
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.17 2007/06/03 07:35:24 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.18 2007/06/06 14:39:45 jokey Exp $
+
+*virtualbox-1.4.0 (06 Jun 2007)
+
+ 06 Jun 2007; Markus Ullmann <jokey@gentoo.org> +virtualbox-1.4.0.ebuild:
+ Version bump, thanks to Alessio
03 Jun 2007; Markus Ullmann <jokey@gentoo.org> virtualbox-9999.ebuild:
Fix hal use dep bug #180565
diff --git a/app-emulation/virtualbox/files/digest-virtualbox-1.4.0 b/app-emulation/virtualbox/files/digest-virtualbox-1.4.0
new file mode 100644
index 000000000000..dbee8ac1a533
--- /dev/null
+++ b/app-emulation/virtualbox/files/digest-virtualbox-1.4.0
@@ -0,0 +1,3 @@
+MD5 8e89d32a67a3a39271f44039d0583a16 VirtualBox-OSE-1.4.0.tar.bz2 21720127
+RMD160 60a445f8ee68b834f19d8004c329e0aed426a15b VirtualBox-OSE-1.4.0.tar.bz2 21720127
+SHA256 32307799f1d03fd9e87b23588279a627ac3856fbea3d4c44f50a2b9c4194a434 VirtualBox-OSE-1.4.0.tar.bz2 21720127
diff --git a/app-emulation/virtualbox/virtualbox-1.4.0.ebuild b/app-emulation/virtualbox/virtualbox-1.4.0.ebuild
new file mode 100644
index 000000000000..1a9764caa404
--- /dev/null
+++ b/app-emulation/virtualbox/virtualbox-1.4.0.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+inherit eutils flag-o-matic qt3 toolchain-funcs
+
+MY_P=VirtualBox-OSE-${PV}
+DESCRIPTION="Softwarefamily of powerful x86 virtualization"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://www.virtualbox.org/download/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="additions alsa hal nowrapper sdk vboxbfe"
+
+RDEPEND="!app-emulation/virtualbox-bin
+ ~app-emulation/virtualbox-modules-${PV}
+ dev-libs/libIDL
+ >=dev-libs/libxslt-1.1.19
+ dev-libs/xalan-c
+ dev-libs/xerces-c
+ media-libs/libsdl
+ x11-libs/libXcursor
+ $(qt_min_version 3.3.5)
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ sys-devel/bin86
+ sys-devel/dev86
+ sys-power/iasl
+ alsa? ( >=media-libs/alsa-lib-1.0.13 )
+ =virtual/libstdc++-3.3"
+RDEPEND="${RDEPEND}
+ additions? ( ~app-emulation/virtualbox-additions-${PV} )"
+
+S=${WORKDIR}/VirtualBox-OSE-${PV}
+
+pkg_setup() {
+ # The VBoxSDL frontend needs media-libs/libsdl compiled
+ # with USE flag X enabled (bug #177335)
+ if ! built_with_use media-libs/libsdl X; then
+ eerror "media-libs/libsdl was compiled without the \"X\" USE flag enabled."
+ eerror "Please re-emerge media-libs/libsdl with USE=\"X\"."
+ die "media-libs/libsdl should be compiled with the \"X\" USE flag."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ local myconf
+ if ! use hal; then
+ myconf="${myconf} --without-hal"
+ fi
+
+ # Don't build vboxdrv and additions: splitted into separate ebuilds
+ epatch "${FILESDIR}/${P}-remove-splitted-stuff.patch"
+ # Don't build the Alsa audio driver and remove Alsa checks in configure
+ # when Alsa is not selected (bug #167739)
+ use alsa || epatch "${FILESDIR}/${P}-remove-alsa.patch"
+}
+
+src_compile() {
+ cd "${S}"
+ ./configure || die "configure failed"
+ source ./env.sh
+
+ # Force kBuild to respect C[XX]FLAGS and MAKEOPTS (bug #178529)
+ # and strip all flags
+ strip-flags
+
+ MAKE="kmk" emake TOOL_GCC3_CC="$(tc-getCC)" TOOL_GCC3_CXX="$(tc-getCXX)" \
+ TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
+ TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \
+ TOOL_GCC3_CFLAGS="${CFLAGS}" TOOL_GCC3_CXXFLAGS="${CXXFLAGS}" \
+ all || die "kmk failed"
+}
+
+src_install() {
+ cd "${S}"/out/linux.${ARCH}/release/bin
+
+ insinto /opt/VirtualBox
+ if use sdk; then
+ doins -r sdk
+ make_wrapper xpidl "sdk/bin/xpidl" "/opt/VirtualBox" "/opt/VirtualBox" "/usr/bin"
+ fperms 0755 /opt/VirtualBox/sdk/bin/xpidl
+ fi
+ if use vboxbfe; then
+ doins VBoxBFE
+ fperms 0755 /opt/VirtualBox/VBoxBFE
+
+ if use nowrapper ; then
+ make_wrapper vboxbfe "./VBoxBFE" "/opt/VirtualBox" "/opt/VirtualBox" "/usr/bin"
+ else
+ dosym /opt/VirtualBox/wrapper.sh /usr/bin/vboxbfe
+ fi
+ fi
+
+ rm -rf sdk src tst* testcase VBoxBFE vditool xpidl SUPInstall SUPUninstall
+
+ doins -r *
+ for each in VBox{Manage,SDL,SVC,XPCOMIPCD} VirtualBox ; do
+ fperms 0755 /opt/VirtualBox/${each}
+ done
+
+ if use nowrapper ; then
+ make_wrapper vboxsvc "./VBoxSVC" "/opt/VirtualBox" "/opt/VirtualBox" "/usr/bin"
+ make_wrapper virtualbox "./VirtualBox" "/opt/VirtualBox" "/opt/VirtualBox" "/usr/bin"
+ make_wrapper vboxmanage "./VBoxManage" "/opt/VirtualBox" "/opt/VirtualBox" "/usr/bin"
+ make_wrapper vboxsdl "./VBoxSDL" "/opt/VirtualBox" "/opt/VirtualBox" "/usr/bin"
+ else
+ exeinto /opt/VirtualBox
+ newexe "${FILESDIR}/${PN}-wrapper" "wrapper.sh"
+ dosym /opt/VirtualBox/wrapper.sh /usr/bin/virtualbox
+ dosym /opt/VirtualBox/wrapper.sh /usr/bin/vboxmanage
+ dosym /opt/VirtualBox/wrapper.sh /usr/bin/vboxsdl
+ fi
+
+ # desktop entry
+ insinto /usr/share/pixmaps
+ newins "${S}"/src/VBox/Frontends/VirtualBox/images/ico32x01.png ${PN}.png
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+}
+
+pkg_postinst() {
+ elog ""
+ if use nowrapper; then
+ elog "In order to launch VirtualBox you need to start the"
+ elog "VirtualBox XPCom Server first, with:"
+ elog "vboxsvc --daemonize && virtualbox"
+ else
+ elog "To launch VirtualBox just type: \"virtualbox\""
+ fi
+ elog ""
+ elog "You must be in the vboxusers group to use VirtualBox,"
+ elog "\"vditool\" is now deprecated, use \"VBoxManage\" instead."
+ elog ""
+ elog "The last user manual is available for download at:"
+ elog "http://www.virtualbox.org/download/UserManual.pdf"
+ elog ""
+}