summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-01-06 21:29:50 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2012-01-06 21:29:50 +0000
commit2cd435d2caaa9667d4f88231d5d0a1196b093539 (patch)
treeea56c1d4bd35e9824777ca8f8f6e06b9e4f144e8 /app-emulation/vmware-modules
parent[dev-db/mysql] Bumped EAPI to 4 on ebuilds inheriting the mysql-v2 eclass as ... (diff)
downloadgentoo-2-2cd435d2caaa9667d4f88231d5d0a1196b093539.tar.gz
gentoo-2-2cd435d2caaa9667d4f88231d5d0a1196b093539.tar.bz2
gentoo-2-2cd435d2caaa9667d4f88231d5d0a1196b093539.zip
fixed patch for 3.2.0 kernel . Bug 397733.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/ChangeLog5
-rw-r--r--app-emulation/vmware-modules/files/264-3.2.0.patch20
2 files changed, 19 insertions, 6 deletions
diff --git a/app-emulation/vmware-modules/ChangeLog b/app-emulation/vmware-modules/ChangeLog
index fe9907338397..3a49a8074ddb 100644
--- a/app-emulation/vmware-modules/ChangeLog
+++ b/app-emulation/vmware-modules/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/vmware-modules
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.85 2012/01/06 14:30:38 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.86 2012/01/06 21:29:50 vadimk Exp $
+
+ 06 Jan 2012; Vadim Kuznetsov <vadimk@gentoo.org> files/264-3.2.0.patch:
+ fixed patch for 3.2.0 kernel . Bug 397733.
06 Jan 2012; Vadim Kuznetsov <vadimk@gentoo.org> +files/264-3.2.0.patch,
vmware-modules-264.1.ebuild:
diff --git a/app-emulation/vmware-modules/files/264-3.2.0.patch b/app-emulation/vmware-modules/files/264-3.2.0.patch
index 60a0be288765..5baa61df9e9d 100644
--- a/app-emulation/vmware-modules/files/264-3.2.0.patch
+++ b/app-emulation/vmware-modules/files/264-3.2.0.patch
@@ -1,5 +1,5 @@
diff --git a/vmmon-only/linux/iommu.c b/vmmon-only/linux/iommu.c
-index c692c2d..e8b6099 100644
+index c692c2d..501d602 100644
--- a/vmmon-only/linux/iommu.c
+++ b/vmmon-only/linux/iommu.c
@@ -42,6 +42,12 @@
@@ -31,14 +31,14 @@ index 491add5..74f7a3b 100644
#define VNET_FILTER_ACTION_DRP (1)
#define VNET_FILTER_ACTION_DRP_SHORT (2)
diff --git a/vmnet-only/netif.c b/vmnet-only/netif.c
-index 4bdb643..540301c 100644
+index 4bdb643..5b71339 100644
--- a/vmnet-only/netif.c
+++ b/vmnet-only/netif.c
@@ -62,7 +62,9 @@ static int VNetNetifClose(struct net_device *dev);
static int VNetNetifStartXmit(struct sk_buff *skb, struct net_device *dev);
static struct net_device_stats *VNetNetifGetStats(struct net_device *dev);
static int VNetNetifSetMAC(struct net_device *dev, void *addr);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
static void VNetNetifSetMulticast(struct net_device *dev);
+#endif
#if 0
@@ -54,11 +54,21 @@ index 4bdb643..540301c 100644
/*
* We cannot stuck... If someone will report problems under
* low memory conditions or some such, we should enable it.
-@@ -612,11 +616,12 @@ VNetNetifSetMAC(struct net_device *dev, // IN:
+@@ -152,7 +156,9 @@ VNetNetIfSetup(struct net_device *dev) // IN:
+ dev->stop = VNetNetifClose;
+ dev->get_stats = VNetNetifGetStats;
+ dev->set_mac_address = VNetNetifSetMAC;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
+ dev->set_multicast_list = VNetNetifSetMulticast;
++#endif
+ /*
+ * We cannot stuck... If someone will report problems under
+ * low memory conditions or some such, we should enable it.
+@@ -612,11 +618,12 @@ VNetNetifSetMAC(struct net_device *dev, // IN:
*----------------------------------------------------------------------
*/
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 2, 0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 2, 0)
void
VNetNetifSetMulticast(struct net_device *dev) // IN: unused
{