summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-18 11:14:30 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-18 11:14:30 +0000
commit2470e86776a5043f8b1ac3f64a057d58ff0e5ebb (patch)
treec08ddc9b7f9463050306a416de64faa1ce56a917 /app-emulation/vov/vov-2.0.0.ebuild
parentadded local USE flag gprof for upcoming package vov (diff)
downloadgentoo-2-2470e86776a5043f8b1ac3f64a057d58ff0e5ebb.tar.gz
gentoo-2-2470e86776a5043f8b1ac3f64a057d58ff0e5ebb.tar.bz2
gentoo-2-2470e86776a5043f8b1ac3f64a057d58ff0e5ebb.zip
Initial import.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emulation/vov/vov-2.0.0.ebuild')
-rw-r--r--app-emulation/vov/vov-2.0.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/vov/vov-2.0.0.ebuild b/app-emulation/vov/vov-2.0.0.ebuild
new file mode 100644
index 000000000000..f74e749183b5
--- /dev/null
+++ b/app-emulation/vov/vov-2.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vov/vov-2.0.0.ebuild,v 1.1 2008/02/18 11:14:30 s4t4n Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="vov (Vov's Obsessive Von-Neumann) is a tool that emulates the behavior of a Von-Neumann machine."
+HOMEPAGE="http://home.gna.org/vov/"
+SRC_URI="http://download.gna.org/vov/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug gprof"
+
+RDEPEND="virtual/libc"
+DEPEND=">=sys-devel/flex-2.5.33-r3
+ >=sys-apps/sed-4.1.5"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # do no install redundant documentation
+ cd "${S}"
+ sed -i 's/src scripts docs/src scripts/' "${S}/Makefile.in"
+}
+
+src_compile()
+{
+ local fp_support=""
+
+ if use gprof; then
+ filter-flags "-fomit-frame-pointer"
+ fp_support="--enable-frame-pointer"
+ fi
+
+ econf \
+ `use_enable gprof` \
+ `use_enable debug` \
+ ${fp_support} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS
+ doman docs/vov.1
+}