summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-14 03:20:51 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-14 03:20:51 +0000
commit980977514f87f47990941b99b1d7e6cb41fe81d1 (patch)
treeb42497eba49bd2623cd00f4620ef2087ad21ae8a /app-emulation/wine/wine-1.2.2.ebuild
parentRemoved vulnerable versions (diff)
downloadgentoo-2-980977514f87f47990941b99b1d7e6cb41fe81d1.tar.gz
gentoo-2-980977514f87f47990941b99b1d7e6cb41fe81d1.tar.bz2
gentoo-2-980977514f87f47990941b99b1d7e6cb41fe81d1.zip
Update to EAPI4 and require USE=threads on glibc-based systems (bug #286560, #396395, and other duplicates). Drop esd support since media-sound/esound has been masked for removal.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/wine/wine-1.2.2.ebuild')
-rw-r--r--app-emulation/wine/wine-1.2.2.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/app-emulation/wine/wine-1.2.2.ebuild b/app-emulation/wine/wine-1.2.2.ebuild
index 0eaf2426af4d..dddd32e502ea 100644
--- a/app-emulation/wine/wine-1.2.2.ebuild
+++ b/app-emulation/wine/wine-1.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.2.2.ebuild,v 1.12 2011/09/18 09:08:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.2.2.ebuild,v 1.13 2012/01/14 03:20:51 tetromino Exp $
-EAPI="2"
+EAPI="4"
inherit eutils flag-o-matic multilib
@@ -30,7 +30,8 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hardened jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus elibc_glibc fontconfig +gecko gnutls gphoto2 gsm hardened jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+REQUIRED_USE="elibc_glibc? ( threads )" #286560
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
@@ -67,7 +68,6 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
)
xinerama? ( x11-libs/libXinerama )
alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
nas? ( media-libs/nas )
cups? ( net-print/cups )
opengl? ( virtual/opengl )
@@ -135,7 +135,7 @@ do_configure() {
$(use_with lcms cms) \
$(use_with cups) \
$(use_with ncurses curses) \
- $(use_with esd) \
+ --without-esd \
$(use_with fontconfig) \
$(use_with gnutls) \
$(use_with gphoto2 gphoto) \
@@ -164,7 +164,7 @@ do_configure() {
$(use_with xml xslt) \
$2
- emake -j1 depend || die "depend"
+ emake -j1 depend
popd >/dev/null
}
@@ -185,7 +185,7 @@ src_compile() {
for b in 64 32 ; do
local builddir="${WORKDIR}/wine${b}"
[[ -d ${builddir} ]] || continue
- emake -C "${builddir}" all || die
+ emake -C "${builddir}" all
done
}
@@ -194,12 +194,12 @@ src_install() {
for b in 64 32 ; do
local builddir="${WORKDIR}/wine${b}"
[[ -d ${builddir} ]] || continue
- emake -C "${builddir}" install DESTDIR="${D}" || die
+ emake -C "${builddir}" install DESTDIR="${D}"
done
dodoc ANNOUNCE AUTHORS README
if use gecko ; then
insinto /usr/share/wine/gecko
- doins "${DISTDIR}"/wine_gecko-${GV}.cab || die
+ doins "${DISTDIR}"/wine_gecko-${GV}.cab
fi
if ! use perl ; then
rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die