summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-05 06:27:13 +0000
committerMike Frysinger <vapier@gentoo.org>2015-08-05 06:27:13 +0000
commit2a65a1ca1c0272d65dc889498a63aef49ba5d71f (patch)
treef80b369604ade777e62db62d38b57b137dace1ea /app-emulation
parentBlock sys-apps/utempter due to file collisions, bug #556644 (diff)
downloadgentoo-2-2a65a1ca1c0272d65dc889498a63aef49ba5d71f.tar.gz
gentoo-2-2a65a1ca1c0272d65dc889498a63aef49ba5d71f.tar.bz2
gentoo-2-2a65a1ca1c0272d65dc889498a63aef49ba5d71f.zip
Unify target logic a bit.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog5
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild31
2 files changed, 16 insertions, 20 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 7a5f2a59ba1b..ed0cce0f5c63 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.345 2015/08/04 08:19:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.346 2015/08/05 06:27:13 vapier Exp $
+
+ 05 Aug 2015; Mike Frysinger <vapier@gentoo.org> qemu-9999.ebuild:
+ Unify target logic a bit.
04 Aug 2015; Agostino Sarubbo <ago@gentoo.org> qemu-2.3.0-r5.ebuild:
Stable for x86, wrt bug #556630
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index de2012b90879..57a8d128a88c 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.103 2015/07/25 19:30:13 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.104 2015/08/05 06:27:13 vapier Exp $
EAPI=5
@@ -294,9 +294,11 @@ qemu_src_configure() {
debug-print-function ${FUNCNAME} "$@"
local buildtype=$1
- local builddir=$2
+ local builddir="${S}/${buildtype}-build"
local static_flag="static-${buildtype}"
+ mkdir "${builddir}"
+
# audio options
local audio_opts="oss"
use alsa && audio_opts="alsa,${audio_opts}"
@@ -378,7 +380,6 @@ qemu_src_configure() {
conf_opts+=(
--enable-linux-user
--disable-system
- --target-list="${user_targets}"
--disable-blobs
--disable-tools
)
@@ -387,7 +388,6 @@ qemu_src_configure() {
conf_opts+=(
--disable-linux-user
--enable-system
- --target-list="${softmmu_targets}"
--with-system-pixman
--audio-drv-list="${audio_opts}"
)
@@ -396,6 +396,9 @@ qemu_src_configure() {
;;
esac
+ local targets="${buildtype}_targets"
+ conf_opts+=( --target-list="${!targets}" )
+
# Add support for SystemTAP
use systemtap && conf_opts+=( --enable-trace-backend=dtrace )
@@ -408,7 +411,7 @@ qemu_src_configure() {
gcc-specs-pie && conf_opts+=( --enable-pie )
fi
- einfo "../configure ${conf_opts[*]}"
+ echo "../configure ${conf_opts[*]}"
cd "${builddir}"
../configure "${conf_opts[@]}" || die "configure failed"
@@ -440,21 +443,11 @@ src_configure() {
fi
done
- [[ -n ${softmmu_targets} ]] && \
- einfo "Building the following softmmu targets: ${softmmu_targets}"
-
- [[ -n ${user_targets} ]] && \
- einfo "Building the following user targets: ${user_targets}"
-
- if [[ -n ${softmmu_targets} ]]; then
- mkdir "${S}/softmmu-build"
- qemu_src_configure "softmmu" "${S}/softmmu-build"
- fi
+ softmmu_targets=${softmmu_targets#,}
+ user_targets=${user_targets#,}
- if [[ -n ${user_targets} ]]; then
- mkdir "${S}/user-build"
- qemu_src_configure "user" "${S}/user-build"
- fi
+ [[ -n ${softmmu_targets} ]] && qemu_src_configure "softmmu"
+ [[ -n ${user_targets} ]] && qemu_src_configure "user"
}
src_compile() {