summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-15 12:35:57 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-15 12:35:57 +0000
commit317513a87b2f32dccd0a726b66a0774323dd5d18 (patch)
tree478293a64cfd4c192b23bb835b6184f576e967f0 /app-emulation
parentFix for Prefix, bug #470064 (diff)
downloadgentoo-2-317513a87b2f32dccd0a726b66a0774323dd5d18.tar.gz
gentoo-2-317513a87b2f32dccd0a726b66a0774323dd5d18.tar.bz2
gentoo-2-317513a87b2f32dccd0a726b66a0774323dd5d18.zip
Rename mime-handler USE flag to run-exes in order to be more clear about its effects.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/metadata.xml2
-rw-r--r--app-emulation/wine/wine-1.6_rc2.ebuild6
-rw-r--r--app-emulation/wine/wine-9999.ebuild6
4 files changed, 13 insertions, 8 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 46c5f419fda1..ae4379b6fb19 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.467 2013/06/15 03:51:49 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.468 2013/06/15 12:35:57 tetromino Exp $
+
+ 15 Jun 2013; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.6_rc2.ebuild,
+ wine-9999.ebuild, metadata.xml:
+ Rename mime-handler USE flag to run-exes in order to be more clear about its
+ effects.
*wine-1.6_rc2 (15 Jun 2013)
diff --git a/app-emulation/wine/metadata.xml b/app-emulation/wine/metadata.xml
index fc70bef1044a..9653a134bc08 100644
--- a/app-emulation/wine/metadata.xml
+++ b/app-emulation/wine/metadata.xml
@@ -11,12 +11,12 @@ Think of Wine as a compatibility layer for running Windows programs. Wine does n
<flag name='capi'>Enable ISDN support via CAPI</flag>
<flag name='custom-cflags'>Bypass strip-flags; use are your own peril</flag>
<flag name='gecko'>Add support for the Gecko engine when using iexplore</flag>
- <flag name='mime-handler'>Register Wine as a handler for .EXE and .MSI files</flag>
<flag name='mono'>Add support for .NET using Wine's Mono add-on</flag>
<flag name='opencl'>Enable OpenCL support</flag>
<flag name='osmesa'>Add support for OpenGL in bitmaps using libOSMesa</flag>
<flag name='perl'>Install helpers written in perl (winedump/winemaker)</flag>
<flag name='prelink'>Run prelink on DLLs during build -- do not disable if you do not know what this means as it can break things at runtime</flag>
+ <flag name='run-exes'>Use Wine to open and run .EXE and .MSI files</flag>
<flag name='samba'>Add support for NTLM auth. see
http://wiki.winehq.org/NtlmAuthSetupGuide and
http://wiki.winehq.org/NtlmSigningAndSealing</flag>
diff --git a/app-emulation/wine/wine-1.6_rc2.ebuild b/app-emulation/wine/wine-1.6_rc2.ebuild
index a5eace1ba61c..251d45b3f802 100644
--- a/app-emulation/wine/wine-1.6_rc2.ebuild
+++ b/app-emulation/wine/wine-1.6_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6_rc2.ebuild,v 1.1 2013/06/15 03:51:49 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6_rc2.ebuild,v 1.2 2013/06/15 12:35:57 tetromino Exp $
EAPI="5"
@@ -39,7 +39,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mime-handler +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
@@ -182,7 +182,7 @@ src_prepare() {
tools/make_requests || die #432348
fi
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
- if ! use mime-handler; then
+ if ! use run-exes; then
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
fi
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index c683bcd92047..355e817e8938 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.145 2013/06/15 03:51:49 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.146 2013/06/15 12:35:57 tetromino Exp $
EAPI="5"
@@ -39,7 +39,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mime-handler +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
@@ -182,7 +182,7 @@ src_prepare() {
tools/make_requests || die #432348
fi
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
- if ! use mime-handler; then
+ if ! use run-exes; then
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
fi