summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-03-26 22:21:55 +0000
committerVlastimil Babka <caster@gentoo.org>2008-03-26 22:21:55 +0000
commit3c3b8b00ea718cedf5c34341c7b5c983fb075641 (patch)
tree8d417b6784e2aad8d8d521a8b046c62bbda3288c /app-emulation
parentamd64/x86 stable, security bug #214812 (diff)
downloadgentoo-2-3c3b8b00ea718cedf5c34341c7b5c983fb075641.tar.gz
gentoo-2-3c3b8b00ea718cedf5c34341c7b5c983fb075641.tar.bz2
gentoo-2-3c3b8b00ea718cedf5c34341c7b5c983fb075641.zip
Version bump, security bug #212425.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog10
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild98
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild97
3 files changed, 204 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index 84af99350ef7..4e9fc0f5fb36 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/emul-linux-x86-java
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.47 2008/03/20 21:02:31 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.48 2008/03/26 22:21:55 caster Exp $
+
+*emul-linux-x86-java-1.6.0.05 (26 Mar 2008)
+*emul-linux-x86-java-1.5.0.15 (26 Mar 2008)
+
+ 26 Mar 2008; Vlastimil Babka <caster@gentoo.org>
+ +emul-linux-x86-java-1.5.0.15.ebuild,
+ +emul-linux-x86-java-1.6.0.05.ebuild:
+ Version bump, security bug #212425.
20 Mar 2008; Peter Volkov <pva@gentoo.org>
emul-linux-x86-java-1.4.2.17.ebuild:
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild
new file mode 100644
index 000000000000..0be008d4172e
--- /dev/null
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.5.0.15.ebuild,v 1.1 2008/03/26 22:21:55 caster Exp $
+
+inherit versionator pax-utils eutils java-vm-2
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
+
+At="jdk-${MY_PV}-dlj-linux-i586.bin"
+DESCRIPTION="32bit version Sun's J2SE Development Kit"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="http://download.java.net/dlj/binaries/${At}"
+
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64"
+RESTRICT="strip"
+IUSE="X alsa nsplugin"
+
+JAVA_VM_NO_GENERATION1=true
+
+RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
+ X? ( app-emulation/emul-linux-x86-xlibs )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ if [[ ! -r ${DISTDIR}/${At} ]]; then
+ die "cannot read ${At}. Please check the permission and try again."
+ fi
+
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh ${DISTDIR}/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}"/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+
+ "${S}"/bin/java -client -Xshare:dump
+}
+
+src_install() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ dodir /opt/${P}
+ cp -pPR bin lib man javaws plugin "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="X11 libraries and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild
new file mode 100644
index 000000000000..20c9dcd264ca
--- /dev/null
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.05.ebuild,v 1.1 2008/03/26 22:21:55 caster Exp $
+
+inherit versionator pax-utils java-vm-2 eutils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+
+At="jdk-${MY_PV}-dlj-linux-i586.bin"
+DESCRIPTION="32bit version Sun's J2SE Development Kit"
+HOMEPAGE="http://java.sun.com/javase/6/"
+#SRC_URI="http://download.java.net/dlj/binaries/${At}"
+SRC_URI="http://dlc.sun.com/dlj/binaries/${At}"
+
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64"
+RESTRICT="strip"
+IUSE="X alsa nsplugin"
+
+JAVA_VM_NO_GENERATION1=true
+
+RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
+ X? ( app-emulation/emul-linux-x86-xlibs )
+ app-emulation/emul-linux-x86-compat"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so
+ opt/${P}/lib/i386/client/libjvm.so
+ opt/${P}/lib/i386/server/libjvm.so"
+
+src_unpack() {
+ if [[ ! -r "${DISTDIR}"/${A} ]]; then
+ die "cannot read ${DISTDIR}/${A}. Please check the permission and try again."
+ fi
+
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}"/construct-${SLOT}.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct-${SLOT}.sh failed"
+
+ "${S}"/bin/java -client -Xshare:dump
+}
+
+src_install() {
+ local dirs="bin lib man javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+
+ pax-mark m $(list-paxables "${D}"/opt/${P}/bin/*)
+
+ dodoc README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+ dodir /opt/${P}/share/
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="X11 libraries and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+}