summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-01 09:05:51 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-01 09:05:51 +0000
commit65bc85a383bed657035f41152543e6a601927d8c (patch)
treee8d85e04a6b83c1e48b168776708571791bd5ec0 /app-emulation
parentAdd ipv6 USE flag. (diff)
downloadgentoo-2-65bc85a383bed657035f41152543e6a601927d8c.tar.gz
gentoo-2-65bc85a383bed657035f41152543e6a601927d8c.tar.bz2
gentoo-2-65bc85a383bed657035f41152543e6a601927d8c.zip
Restore call to multilib_toolchain_setup for 32bit builds on amd64 #257038.
(Portage version: 2.2_rc23/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog8
-rw-r--r--app-emulation/wine/wine-1.1.13.ebuild8
-rw-r--r--app-emulation/wine/wine-1.1.14.ebuild8
-rw-r--r--app-emulation/wine/wine-1.1.15.ebuild6
-rw-r--r--app-emulation/wine/wine-1.1.16.ebuild6
-rw-r--r--app-emulation/wine/wine-9999.ebuild6
6 files changed, 34 insertions, 8 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 6f77cfa9fc41..bb2b8f75d583 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.251 2009/03/01 08:10:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.252 2009/03/01 09:05:51 vapier Exp $
+
+ 01 Mar 2009; Mike Frysinger <vapier@gentoo.org> wine-1.1.13.ebuild,
+ wine-1.1.14.ebuild, wine-1.1.15.ebuild, wine-1.1.16.ebuild,
+ wine-9999.ebuild:
+ Restore call to multilib_toolchain_setup for 32bit builds on amd64
+ #257038.
*wine-1.1.16 (28 Feb 2009)
diff --git a/app-emulation/wine/wine-1.1.13.ebuild b/app-emulation/wine/wine-1.1.13.ebuild
index 1906f46ddab7..41d93025cd53 100644
--- a/app-emulation/wine/wine-1.1.13.ebuild
+++ b/app-emulation/wine/wine-1.1.13.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.13.ebuild,v 1.7 2009/01/31 15:25:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.13.ebuild,v 1.8 2009/03/01 09:05:51 vapier Exp $
EAPI="2"
+inherit multilib
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
inherit git
@@ -16,7 +18,7 @@ else
S=${WORKDIR}/${MY_P}
fi
-GV="0.9.0"
+GV="0.9.1"
DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
@@ -89,6 +91,8 @@ src_prepare() {
src_configure() {
export LDCONFIG=/bin/true
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
# XXX: should check out these flags too:
# audioio capi fontconfig freetype gphoto
econf \
diff --git a/app-emulation/wine/wine-1.1.14.ebuild b/app-emulation/wine/wine-1.1.14.ebuild
index 8d6221b67881..d4cfa23a7c61 100644
--- a/app-emulation/wine/wine-1.1.14.ebuild
+++ b/app-emulation/wine/wine-1.1.14.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.14.ebuild,v 1.2 2009/01/31 15:27:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.14.ebuild,v 1.3 2009/03/01 09:05:51 vapier Exp $
EAPI="2"
+inherit multilib
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
inherit git
@@ -16,7 +18,7 @@ else
S=${WORKDIR}/${MY_P}
fi
-GV="0.9.0"
+GV="0.9.1"
DESCRIPTION="free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
@@ -89,6 +91,8 @@ src_prepare() {
src_configure() {
export LDCONFIG=/bin/true
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
# XXX: should check out these flags too:
# audioio capi fontconfig freetype gphoto
econf \
diff --git a/app-emulation/wine/wine-1.1.15.ebuild b/app-emulation/wine/wine-1.1.15.ebuild
index ba6ef250c537..1fe8030a2428 100644
--- a/app-emulation/wine/wine-1.1.15.ebuild
+++ b/app-emulation/wine/wine-1.1.15.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.15.ebuild,v 1.1 2009/02/13 18:47:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.15.ebuild,v 1.2 2009/03/01 09:05:51 vapier Exp $
EAPI="2"
+inherit multilib
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
inherit git
@@ -89,6 +91,8 @@ src_prepare() {
src_configure() {
export LDCONFIG=/bin/true
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
# XXX: should check out these flags too:
# audioio capi fontconfig freetype gphoto
econf \
diff --git a/app-emulation/wine/wine-1.1.16.ebuild b/app-emulation/wine/wine-1.1.16.ebuild
index 66e37839bb78..548213ad2238 100644
--- a/app-emulation/wine/wine-1.1.16.ebuild
+++ b/app-emulation/wine/wine-1.1.16.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.16.ebuild,v 1.1 2009/03/01 08:10:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.16.ebuild,v 1.2 2009/03/01 09:05:51 vapier Exp $
EAPI="2"
+inherit multilib
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
inherit git
@@ -89,6 +91,8 @@ src_prepare() {
src_configure() {
export LDCONFIG=/bin/true
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
# XXX: should check out these flags too:
# audioio capi fontconfig freetype gphoto
econf \
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 6e651d5d30c8..14f1ff09649e 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.33 2009/02/05 19:44:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.34 2009/03/01 09:05:51 vapier Exp $
EAPI="2"
+inherit multilib
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
inherit git
@@ -89,6 +91,8 @@ src_prepare() {
src_configure() {
export LDCONFIG=/bin/true
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
# XXX: should check out these flags too:
# audioio capi fontconfig freetype gphoto
econf \