summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevyn Shortell <trance@gentoo.org>2002-09-08 07:46:16 +0000
committerKevyn Shortell <trance@gentoo.org>2002-09-08 07:46:16 +0000
commit7c9ae9a0eb3aa684de458cd7b1399223fd962004 (patch)
tree1612e6f9d9b061d82b3edb297dca43da5f0507f4 /app-emulation
parentNew version 0.98.34 (diff)
downloadgentoo-2-7c9ae9a0eb3aa684de458cd7b1399223fd962004.tar.gz
gentoo-2-7c9ae9a0eb3aa684de458cd7b1399223fd962004.tar.bz2
gentoo-2-7c9ae9a0eb3aa684de458cd7b1399223fd962004.zip
Updating to MOL .65
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mol/mol-0.9.65.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/mol/mol-0.9.65.ebuild b/app-emulation/mol/mol-0.9.65.ebuild
new file mode 100644
index 000000000000..91b082304396
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.65.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.65.ebuild,v 1.1 2002/09/08 07:46:16 trance Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MOL (Mac-on-Linux) is a PPC-only program to run Mac OS <=9.2 natively within Linux"
+SRC_URI="ftp://ftp.nada.kth.se/pub/home/f95-sry/Public/mac-on-linux/${P}.tgz"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="ppc -x86 -sparc -sparc64"
+
+pkg_setup() {
+ if [ ${ARCH} != "ppc" ] ; then
+ eerror "Sorry, this is a PPC only package."
+ die "Sorry, this as a PPC only pacakge."
+ fi
+}
+
+src_compile() {
+
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ emake || die "Failed to compile MOL"
+}
+
+src_install() {
+
+ emake DESTDIR=${D} install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol"
+ einfo "You might want to configure video modes first with molvconfig"
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+}