summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-01-17 17:51:26 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-01-17 17:51:26 +0000
commit80065e59ec3715bc6c3688e6905d5bb8ac92809a (patch)
treee98fac941c423bb855a90f1bd625c9d8f41f1559 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-80065e59ec3715bc6c3688e6905d5bb8ac92809a.tar.gz
gentoo-2-80065e59ec3715bc6c3688e6905d5bb8ac92809a.tar.bz2
gentoo-2-80065e59ec3715bc6c3688e6905d5bb8ac92809a.zip
Bump that contains many fixes and patches for various issues reported upstream.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtinst/ChangeLog10
-rw-r--r--app-emulation/virtinst/virtinst-0.600.0-r1.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index d52ae2a38693..c25aabf97442 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/virtinst
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.31 2011/07/28 19:20:30 cardoe Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.32 2012/01/17 17:51:26 cardoe Exp $
+
+*virtinst-0.600.0-r1 (17 Jan 2012)
+
+ 17 Jan 2012; Doug Goldstein <cardoe@gentoo.org> +virtinst-0.600.0-r1.ebuild:
+ Bump that contains many fixes and patches for various issues reported
+ upstream.
28 Jul 2011; Doug Goldstein <cardoe@gentoo.org> virtinst-0.600.0.ebuild,
virtinst-9999.ebuild:
diff --git a/app-emulation/virtinst/virtinst-0.600.0-r1.ebuild b/app-emulation/virtinst/virtinst-0.600.0-r1.ebuild
new file mode 100644
index 000000000000..fd40f9895ff1
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.600.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.600.0-r1.ebuild,v 1.1 2012/01/17 17:51:26 cardoe Exp $
+
+BACKPORTS=1
+
+EAPI=3
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="http://git.fedorahosted.org/git/python-virtinst.git"
+ GIT_ECLASS="git-2"
+fi
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-bp-${BACKPORTS}.tar.bz2
+ http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}