summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-08-13 09:58:58 +0000
committerPeter Volkov <pva@gentoo.org>2007-08-13 09:58:58 +0000
commit894650a8278089fade45a8b25bff1bbf38972a60 (patch)
treea035f8077f2119b4e293f2d9bb184f0d71cce242 /app-emulation
parentOpps. I should never bump into stable... (diff)
downloadgentoo-2-894650a8278089fade45a8b25bff1bbf38972a60.tar.gz
gentoo-2-894650a8278089fade45a8b25bff1bbf38972a60.tar.bz2
gentoo-2-894650a8278089fade45a8b25bff1bbf38972a60.zip
Fix missing sdlgfx.h. Adding OSS. Cleaning old.
(Portage version: 2.1.3.5)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uae/ChangeLog7
-rw-r--r--app-emulation/uae/files/digest-uae-0.8.253
-rw-r--r--app-emulation/uae/files/digest-uae-0.8.25-r13
-rw-r--r--app-emulation/uae/files/sdlgfx.h38
-rw-r--r--app-emulation/uae/files/uae-0.8.25-gtk-ui-cleanup.patch47
-rw-r--r--app-emulation/uae/files/uae-0.8.25-uae_reset_args.diff102
-rw-r--r--app-emulation/uae/uae-0.8.25-r1.ebuild75
-rw-r--r--app-emulation/uae/uae-0.8.25.ebuild77
-rw-r--r--app-emulation/uae/uae-0.8.26.ebuild34
9 files changed, 73 insertions, 313 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 6a48e9e77658..8793a3e88d47 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.29 2007/08/12 15:15:32 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.30 2007/08/13 09:58:58 pva Exp $
+
+ 13 Aug 2007; <pva@gentoo.org> -files/uae-0.8.25-gtk-ui-cleanup.patch,
+ -files/uae-0.8.25-uae_reset_args.diff, +files/sdlgfx.h,
+ -uae-0.8.25.ebuild, -uae-0.8.25-r1.ebuild, uae-0.8.26.ebuild:
+ Fix missing sdlgfx.h. Adding OSS. Cleaning old.
*uae-0.8.26 (12 Aug 2007)
diff --git a/app-emulation/uae/files/digest-uae-0.8.25 b/app-emulation/uae/files/digest-uae-0.8.25
deleted file mode 100644
index 1c1390f95d26..000000000000
--- a/app-emulation/uae/files/digest-uae-0.8.25
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e660ca2bec3c016c978ef88117b0c432 uae-0.8.25.tar.gz 970727
-RMD160 6990dc7aaf43c8bda0d7b86e6d0ae164209d1eb1 uae-0.8.25.tar.gz 970727
-SHA256 611a7e04dd77080d87c7e9680aed997ed2be45116eec91613eb36a85235a686a uae-0.8.25.tar.gz 970727
diff --git a/app-emulation/uae/files/digest-uae-0.8.25-r1 b/app-emulation/uae/files/digest-uae-0.8.25-r1
deleted file mode 100644
index 1c1390f95d26..000000000000
--- a/app-emulation/uae/files/digest-uae-0.8.25-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e660ca2bec3c016c978ef88117b0c432 uae-0.8.25.tar.gz 970727
-RMD160 6990dc7aaf43c8bda0d7b86e6d0ae164209d1eb1 uae-0.8.25.tar.gz 970727
-SHA256 611a7e04dd77080d87c7e9680aed997ed2be45116eec91613eb36a85235a686a uae-0.8.25.tar.gz 970727
diff --git a/app-emulation/uae/files/sdlgfx.h b/app-emulation/uae/files/sdlgfx.h
new file mode 100644
index 000000000000..30bee2ee4024
--- /dev/null
+++ b/app-emulation/uae/files/sdlgfx.h
@@ -0,0 +1,38 @@
+/*
+ * UAE - The Un*x Amiga Emulator
+ *
+ * SDL graphics support
+ *
+ * Copyright 2004 Richard Drummond
+ */
+
+/*
+ * What graphics platform are we running on . . .?
+ *
+ * Yes, SDL is supposed to abstract away from the underlying
+ * platform, but we need to know this to be able to map raw keys
+ * and to work around any platform-specific quirks . . .
+ */
+enum {
+ SDLGFX_DRIVER_UNKNOWN,
+ SDLGFX_DRIVER_X11,
+ SDLGFX_DRIVER_DGA,
+ SDLGFX_DRIVER_SVGALIB,
+ SDLGFX_DRIVER_FBCON,
+ SDLGFX_DRIVER_DIRECTFB,
+ SDLGFX_DRIVER_QUARTZ,
+ SDLGFX_DRIVER_BWINDOW,
+ SDLGFX_DRIVER_CYBERGFX,
+ SDLGFX_DRIVER_AMIGAOS4
+};
+
+extern int get_sdlgfx_type (void);
+
+/* keyboard support */
+struct uae_input_device_kbr_default *get_default_raw_keymap (int type);
+extern int keysym2amiga (int keycode);
+int modifier_hack (int *scancode, int *pressed);
+
+/* hotkey support */
+struct uae_hotkeyseq *get_default_cooked_hotkeys (void);
+struct uae_hotkeyseq *get_default_raw_hotkeys (void);
diff --git a/app-emulation/uae/files/uae-0.8.25-gtk-ui-cleanup.patch b/app-emulation/uae/files/uae-0.8.25-gtk-ui-cleanup.patch
deleted file mode 100644
index 2c05d4d4a511..000000000000
--- a/app-emulation/uae/files/uae-0.8.25-gtk-ui-cleanup.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- uae-0.8.25/src/gtkui.c.orig 2007-02-16 18:40:02.000000000 +0300
-+++ uae-0.8.25/src/gtkui.c 2007-02-16 18:40:06.000000000 +0300
-@@ -762,8 +762,8 @@
- return;
-
- write_comm_pipe_int (&from_gui_pipe, 0, 0);
-- write_comm_pipe_int (&from_gui_pipe, (int)data, 1);
-- gtk_label_set_text (GTK_LABEL (disk_text_widget[(int)data]), "");
-+ write_comm_pipe_int (&from_gui_pipe, GPOINTER_TO_INT(data), 1);
-+ gtk_label_set_text (GTK_LABEL (disk_text_widget[GPOINTER_TO_INT(data)]), "");
- }
-
- static void pause_uae (void)
-@@ -851,7 +851,7 @@
-
- static void did_insert (GtkWidget *w, gpointer data)
- {
-- int n = (int)data;
-+ int n = GPOINTER_TO_INT(data);
- if (filesel_active != -1)
- return;
- filesel_active = n;
-@@ -1131,7 +1131,7 @@
- gdk_color_alloc (colormap, led_off + nr);
- led_widgets[nr] = thing;
- gtk_signal_connect (GTK_OBJECT (thing), "event",
-- (GtkSignalFunc) driveled_event, (gpointer) thing);
-+ (GtkSignalFunc) driveled_event, GINT_TO_POINTER(thing));
- gtk_widget_show (thing);
-
- thing = gtk_preview_new (GTK_PREVIEW_COLOR);
-@@ -1198,13 +1198,13 @@
- gtk_box_pack_start (GTK_BOX (buttonbox), thing, FALSE, TRUE, 0);
- gtk_widget_show (thing);
- disk_eject_widget[i] = thing;
-- gtk_signal_connect (GTK_OBJECT (thing), "clicked", (GtkSignalFunc) did_eject, (gpointer) i);
-+ gtk_signal_connect (GTK_OBJECT (thing), "clicked", (GtkSignalFunc) did_eject, GINT_TO_POINTER(i));
-
- thing = gtk_button_new_with_label ("Insert");
- gtk_box_pack_start (GTK_BOX (buttonbox), thing, FALSE, TRUE, 0);
- gtk_widget_show (thing);
- disk_insert_widget[i] = thing;
-- gtk_signal_connect (GTK_OBJECT (thing), "clicked", (GtkSignalFunc) did_insert, (gpointer) i);
-+ gtk_signal_connect (GTK_OBJECT (thing), "clicked", (GtkSignalFunc) did_insert, GINT_TO_POINTER(i));
- }
-
- add_empty_vbox (vbox);
diff --git a/app-emulation/uae/files/uae-0.8.25-uae_reset_args.diff b/app-emulation/uae/files/uae-0.8.25-uae_reset_args.diff
deleted file mode 100644
index f9bf6e323fc9..000000000000
--- a/app-emulation/uae/files/uae-0.8.25-uae_reset_args.diff
+++ /dev/null
@@ -1,102 +0,0 @@
-uae_reset() now wants some argument!
-
-Antonio Ospite <ospite@studenti.unina.it>
-
-diff -pruN uae-0.8.25___orig/src/ncurses.c uae-0.8.25/src/ncurses.c
---- uae-0.8.25___orig/src/ncurses.c 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/ncurses.c 2006-06-07 17:42:33.000000000 +0200
-@@ -596,7 +596,7 @@ void handle_events(void)
- if (ch == 16) --lastmy; /* ^P */
- if (ch == 11) {buttonstate[0] = keydelay;ch = 0;} /* ^K */
- if (ch == 25) {buttonstate[2] = keydelay;ch = 0;} /* ^Y */
-- if (ch == 15) uae_reset (); /* ^O */
-+ if (ch == 15) uae_reset (0); /* ^O */
- if (ch == 17) uae_quit (); /* ^Q */
- if (ch == KEY_F(1)) {
- curses_insert_disk();
-diff -pruN uae-0.8.25___orig/src/NeXTwin.m uae-0.8.25/src/NeXTwin.m
---- uae-0.8.25___orig/src/NeXTwin.m 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/NeXTwin.m 2006-06-07 17:42:15.000000000 +0200
-@@ -86,7 +86,7 @@ static int keycode2amiga(NXEvent * theEv
- @implementation AmigaView
- -reset:sender
- {
-- uae_reset();
-+ uae_reset(0);
- //m68k_reset();
- return self;
- }
-diff -pruN uae-0.8.25___orig/src/od-beos/beos.cpp uae-0.8.25/src/od-beos/beos.cpp
---- uae-0.8.25___orig/src/od-beos/beos.cpp 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/od-beos/beos.cpp 2006-06-07 17:43:48.000000000 +0200
-@@ -719,7 +719,7 @@ void handle_events(void)
- uint32 mouse_buttons;
-
- if (reset_thyself) {
-- uae_reset();
-+ uae_reset(0);
- reset_thyself = false;
- }
-
-diff -pruN uae-0.8.25___orig/src/od-win32/keyboard.c uae-0.8.25/src/od-win32/keyboard.c
---- uae-0.8.25___orig/src/od-win32/keyboard.c 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/od-win32/keyboard.c 2006-06-07 17:44:04.000000000 +0200
-@@ -489,8 +489,8 @@ int my_kbd_handler (int keycode, int sca
- record_key ((akey << 1) + 1);
-
- /* "Affengriff" */
-- if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_LAMI] && keystate[AK_RAMI])uae_reset();
-- //if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_RAMI])uae_reset();
-+ if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_LAMI] && keystate[AK_RAMI])uae_reset(0);
-+ //if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_RAMI])uae_reset(0);
-
- return 0;
- }
-diff -pruN uae-0.8.25___orig/src/od-win32/win32gui.c uae-0.8.25/src/od-win32/win32gui.c
---- uae-0.8.25___orig/src/od-win32/win32gui.c 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/od-win32/win32gui.c 2006-06-07 17:44:16.000000000 +0200
-@@ -2261,7 +2261,7 @@ static BOOL CALLBACK MiscDlgProc (HWND h
- }
- break;
- case IDC_RESETAMIGA:
-- uae_reset();
-+ uae_reset(0);
- break;
- case IDC_QUITEMU:
- uae_quit();
-diff -pruN uae-0.8.25___orig/src/sdlgfx.c uae-0.8.25/src/sdlgfx.c
---- uae-0.8.25___orig/src/sdlgfx.c 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/sdlgfx.c 2006-06-07 17:42:57.000000000 +0200
-@@ -875,7 +875,7 @@ void handle_events (void)
-
- /* Handle UAE reset */
- if ((keystate[AK_CTRL] || keystate[AK_RCTRL]) && keystate[AK_LAMI] && keystate[AK_RAMI])
-- uae_reset ();
-+ uae_reset (0);
- }
-
- int check_prefs_changed_gfx (void)
-diff -pruN uae-0.8.25___orig/src/svga.c uae-0.8.25/src/svga.c
---- uae-0.8.25___orig/src/svga.c 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/svga.c 2006-06-07 17:43:17.000000000 +0200
-@@ -439,7 +439,7 @@ static void my_kbd_handler (int scancode
-
- /* "Affengriff" */
- if ((keystate[AK_CTRL] || keystate[AK_RCTRL]) && keystate[AK_LAMI] && keystate[AK_RAMI])
-- uae_reset ();
-+ uae_reset (0);
- }
-
- static void leave_graphics_mode (void)
-diff -pruN uae-0.8.25___orig/src/tui.c uae-0.8.25/src/tui.c
---- uae-0.8.25___orig/src/tui.c 2006-06-07 17:41:49.000000000 +0200
-+++ uae-0.8.25/src/tui.c 2006-06-07 17:43:32.000000000 +0200
-@@ -684,7 +684,7 @@ static int do_gui (int mode)
- case 0: DiskOptions (); break;
- case 1: OtherOptions (); break;
- case 2: save_settings (); break;
-- case 3: uae_reset (); break;
-+ case 3: uae_reset (0); break;
- case 4: uae_quit (); break;
- }
- }
diff --git a/app-emulation/uae/uae-0.8.25-r1.ebuild b/app-emulation/uae/uae-0.8.25-r1.ebuild
deleted file mode 100644
index 31b25d54d29a..000000000000
--- a/app-emulation/uae/uae-0.8.25-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25-r1.ebuild,v 1.1 2007/02/16 15:50:01 pva Exp $
-
-inherit eutils
-
-DESCRIPTION="The Umiquious Amiga Emulator"
-HOMEPAGE="http://www.freiburg.linux.de/~uae/"
-SRC_URI="ftp://ftp.freiburg.linux.de/pub/uae/sources/develop/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="X dga svga ncurses alsa sdl-sound scsi gtk"
-
-DEPEND="X? ( x11-libs/libXext
- x11-libs/libXxf86vm
- dga? ( x11-libs/libXxf86dga ) )
- !X? ( svga? ( media-libs/svgalib )
- !svga? ( sys-libs/ncurses ) )
- alsa? ( media-libs/alsa-lib )
- scsi? ( app-cdr/cdrtools )
- gtk? ( x11-libs/gtk+ )"
-
-pkg_setup() {
- if use X ; then
- elog "Enabling X11 for video output."
- my_config="$(use_with X x) $(use_enable X vidmode)"
- use dga && my_config="${my_config} $(use_enable dga)"
- elif use svga ; then
- elog "Enabling svga for video output."
- my_config="$(use_with svga svgalib)"
- elif use ncurses ; then
- elog "Enabling ncurses for video output."
- my_config="$(use_with ncurses asciiart)"
- else
- ewarn "You have not enabled X or svga or ncruses in USE!"
- ewarn "Video output is not selected. Falling back on ncurses..."
- my_config="--with-asciiart"
- fi
-
- my_config="${my_config} $(use_with alsa)"
- my_config="${my_config} $(use_enable gtk ui)"
- my_config="${my_config} $(use_enable scsi scsi-device)"
- my_config="${my_config} --enable-threads"
-}
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}"/${P}-makefile_more_cleaning.diff
- epatch "${FILESDIR}"/${P}-memory_leaks_in_gui.diff
- epatch "${FILESDIR}"/${P}-allow_spaces_in_zip_filenames.diff
- epatch "${FILESDIR}"/${P}-preserve_home_in_writing_optionsfile.diff
- epatch "${FILESDIR}"/${P}-close_window_hack.diff
- epatch "${FILESDIR}"/${P}-struct_uae_wrong_fields_name.diff
- epatch "${FILESDIR}"/${P}-fix_save_config.diff
- epatch "${FILESDIR}"/${P}-uae_reset_args.diff
- epatch "${FILESDIR}"/${P}-fix_static_declatarions.diff
- epatch "${FILESDIR}"/${P}-gtk-ui-cleanup.patch
-}
-
-src_compile() {
- econf ${my_config} || die "configure failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- dobin uae readdisk || die
- cp docs/unix/README docs/README.unix
- dodoc docs/*
-
- insinto /usr/share/uae/amiga-tools
- doins amiga/{*hack,trans*,uae*}
-}
diff --git a/app-emulation/uae/uae-0.8.25.ebuild b/app-emulation/uae/uae-0.8.25.ebuild
deleted file mode 100644
index 0a5045fd5ccb..000000000000
--- a/app-emulation/uae/uae-0.8.25.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25.ebuild,v 1.3 2007/07/12 06:39:56 mr_bones_ Exp $
-
-inherit eutils
-
-DESCRIPTION="The Umiquious Amiga Emulator"
-HOMEPAGE="http://www.freiburg.linux.de/~uae/"
-SRC_URI="ftp://ftp.freiburg.linux.de/pub/uae/sources/develop/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="sdl X dga svga ncurses alsa sdl-sound scsi gtk"
-
-DEPEND="sdl? ( media-libs/libsdl )
- !sdl? ( X? ( x11-libs/libXext
- x11-libs/libXxf86vm
- dga? ( x11-libs/libXxf86dga ) )
- !X? ( svga? ( media-libs/svgalib )
- !svga? ( ncurses? ( sys-libs/ncurses )
- !ncurses? ( media-libs/libsdl ) ) ) )
- alsa? ( media-libs/alsa-lib )
- !alsa? ( sdl-sound? ( media-libs/libsdl ) )
- scsi? ( app-cdr/cdrtools )
- gtk? ( x11-libs/gtk+ )"
-
-pkg_setup() {
- if use sdl ; then
- elog "Enabling sdl for video output."
- my_config="$(use_with sdl) $(use_with sdl sdl-gfx)"
- elif use X ; then
- elog "Enabling X11 for video output."
- my_config="$(use_with X x) $(use_enable X vidmode)"
- use dga && my_config="${my_config} $(use_enable dga)"
- elif use svga ; then
- elog "Enabling svga for video output."
- my_config="$(use_with svga svgalib)"
- elif use ncurses ; then
- elog "Enabling ncurses for video output."
- my_config="$(use_with ncurses asciiart)"
- else
- ewarn "You have not enabled sdl or X or svga or ncruses in USE!"
- ewarn "Video output is not selected. Falling back on sdl..."
- my_config="$(use_with sdl) $(use_with sdl sdl-gfx)"
- fi
-
- if use alsa ; then
- elog "Enabling alsa for sound output."
- my_config="${my_config} $(use_with alsa)"
- elif use sdl-sound ; then
- elog "Enabling sdl for sound output."
- my_config="${my_config} $(use_with sdl sdl-sound)"
- else
- elog "You have not enabled sdl-sound and alsa in USE!"
- elog "Using sound output to file."
- my_config="${my_config} --enable-file-sound"
- fi
-
- use gtk && my_config="${my_config} --enable-ui"
- use scsi && my_config="${my_config} --enable-scsi-device"
- my_config="${my_config} --enable-threads"
-}
-
-src_compile() {
- econf ${my_config} || die "configure failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- dobin uae readdisk || die
- cp docs/unix/README docs/README.unix
- dodoc docs/*
-
- insinto /usr/share/uae/amiga-tools
- doins amiga/{*hack,trans*,uae*}
-}
diff --git a/app-emulation/uae/uae-0.8.26.ebuild b/app-emulation/uae/uae-0.8.26.ebuild
index 3545acad5421..365343e13ea1 100644
--- a/app-emulation/uae/uae-0.8.26.ebuild
+++ b/app-emulation/uae/uae-0.8.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.26.ebuild,v 1.2 2007/08/12 15:36:52 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.26.ebuild,v 1.3 2007/08/13 09:58:58 pva Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.coresystems.de/pub/uae/sources/develop/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="sdl X dga svga aalib alsa sdl-sound scsi ui"
+IUSE="sdl X dga svga aalib oss alsa sdl-sound scsi ui"
DEPEND="sdl? ( media-libs/libsdl
media-libs/sdl-gfx
@@ -46,10 +46,18 @@ src_unpack() {
epatch "${FILESDIR}"/uae-0.8.25-preserve_home_in_writing_optionsfile.diff
epatch "${FILESDIR}"/uae-0.8.25-struct_uae_wrong_fields_name.diff
epatch "${FILESDIR}"/${P}-uae_reset_args.diff
+ cp "${FILESDIR}"/sdlgfx.h "${S}"/src
}
pkg_setup() {
# See configure.in for possible pathes of logic...
+ echo
+ elog "It was told by upstream developer Bernd Schmidt that sdl-sound is"
+ elog "broken now and alsa driver seems to be not in best shape. So OSS"
+ elog "(don't forget alsa emulation of OSS) is prefered, but it'll be"
+ elog "autodetected and thus it's possible that uae misses it and you'll"
+ elog "have no error but no sound too. Be carful and report this cases."
+ echo
if use sdl ; then
elog "Enabling sdl for video output."
my_config="$(use_with sdl) $(use_with sdl sdl-gfx)"
@@ -61,7 +69,11 @@ pkg_setup() {
elog "You do not have ui in USE. Disabling UI"
my_config="${my_config} --disable-ui"
fi
- if use sdl-sound ; then
+ if use oss ; then
+ elog "Disabling alsa and sdl-sound and falling back on oss autodetection."
+ elog "You'll have to be carefull: if that fails you'll have no audio."
+ my_config="${my_config} --without-sdl-sound --without-alsa"
+ elif use sdl-sound ; then
elog "Enabling sdl-sound for sound output."
my_config="${my_config} $(use_with sdl-sound)"
elif use alsa ; then
@@ -124,7 +136,11 @@ pkg_setup() {
fi
fi
fi
- if use alsa ; then
+ if use oss ; then
+ elog "Disabling alsa and sdl-sound and falling back on oss autodetection."
+ elog "You'll have to be carefull: if that fails you'll have no audio."
+ my_config="${my_config} --without-sdl-sound --without-alsa"
+ elif use alsa ; then
elog "Enabling alsa for sound output."
my_config="${my_config} $(use_with alsa)"
else
@@ -134,7 +150,7 @@ pkg_setup() {
my_config="${my_config} --enable-file-sound"
fi
fi
-
+ echo
my_config="${my_config} $(use_enable scsi scsi-device)"
my_config="${my_config} --enable-threads"
}
@@ -147,8 +163,16 @@ src_compile() {
src_install() {
dobin uae readdisk || die
cp docs/unix/README docs/README.unix
+ rm -r docs/{AmigaOS,BeOS,pOS,translated,unix}
dodoc docs/*
insinto /usr/share/uae/amiga-tools
doins amiga/{*hack,trans*,uae*}
}
+
+pkg_postinst() {
+ elog
+ elog "Upstream recomends using SDL graphics (with an environment variable"
+ elog "SDL_VIDEO_X11_XRANDR=1 for fullscreen support."
+ echo
+}