summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-12-02 22:41:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-12-02 22:41:41 +0000
commit8db0ab33e0908ade30cb212db9d95430846458c3 (patch)
treefe18681460aa91c7eb28f42413c5fd10a501a996 /app-emulation
parentInitial version of the Python bindings for libvirt that are now split from th... (diff)
downloadgentoo-2-8db0ab33e0908ade30cb212db9d95430846458c3.tar.gz
gentoo-2-8db0ab33e0908ade30cb212db9d95430846458c3.tar.bz2
gentoo-2-8db0ab33e0908ade30cb212db9d95430846458c3.zip
Remove older version
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virt-manager/ChangeLog5
-rw-r--r--app-emulation/virt-manager/virt-manager-0.9.4.ebuild101
2 files changed, 4 insertions, 102 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index 89c9ea0d8f0a..ae70dc1ee37b 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.95 2013/09/25 07:24:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.96 2013/12/02 22:41:41 cardoe Exp $
+
+ 02 Dec 2013; Doug Goldstein <cardoe@gentoo.org> -virt-manager-0.9.4.ebuild:
+ Remove older version
25 Sep 2013; Justin Lecher <jlec@gentoo.org> virt-manager-0.10.0.ebuild,
virt-manager-0.10.0-r1.ebuild, virt-manager-9999.ebuild:
diff --git a/app-emulation/virt-manager/virt-manager-0.9.4.ebuild b/app-emulation/virt-manager/virt-manager-0.9.4.ebuild
deleted file mode 100644
index 3f5865a856e5..000000000000
--- a/app-emulation/virt-manager/virt-manager-0.9.4.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.9.4.ebuild,v 1.5 2013/03/24 00:40:35 cardoe Exp $
-
-EAPI=4
-
-#BACKPORTS=4
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="http://git.fedorahosted.org/git/virt-manager.git"
-fi
-
-PYTHON_DEPEND="2:2.5"
-
-# Stop gnome2.eclass from doing stuff on USE=debug
-GCONF_DEBUG="no"
-
-inherit eutils gnome2 python
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-2 autotools
- SRC_URI=""
- KEYWORDS=""
- VIRTINSTDEP=">=app-emulation/virtinst-9999"
-else
- SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
- ${BACKPORTS:+mirror://gentoo/${P}-bp-${BACKPORTS}.tar.bz2
- http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
- KEYWORDS="amd64 x86"
- VIRTINSTDEP=">=app-emulation/virtinst-0.600.2"
-fi
-
-DESCRIPTION="A graphical tool for administering virtual machines (KVM/Xen)"
-HOMEPAGE="http://virt-manager.org/"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="gnome-keyring policykit sasl +spice +vnc"
-RDEPEND=">=dev-python/pygtk-1.99.12
- >=app-emulation/libvirt-0.7.0[python,sasl?]
- >=dev-libs/libxml2-2.6.23[python]
- ${VIRTINSTDEP}
- >=gnome-base/librsvg-2
- >=x11-libs/vte-0.12.2:0[python]
- >=dev-python/dbus-python-0.61
- >=dev-python/gconf-python-1.99.11
- dev-python/urlgrabber
- sys-apps/dbus[X]
- gnome-keyring? ( dev-python/gnome-keyring-python )
- policykit? ( sys-auth/polkit )
- spice? (
- >=net-misc/spice-gtk-0.6[python,sasl?]
- || (
- <=net-misc/spice-gtk-0.14[python,sasl?,-gtk3]
- >=net-misc/spice-gtk-0.14-r1[python,sasl?]
- )
- )
- vnc? ( >=net-libs/gtk-vnc-0.3.8[python,sasl?] )"
-# tui? ( >=dev-python/new_syrup-0.1.2 )"
-DEPEND="${RDEPEND}
- app-text/rarian
- dev-util/intltool"
-
-pkg_setup() {
- G2CONF="--without-tui"
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- sed -e "s/python/python2/" -i src/virt-manager.in || \
- die "python2 update failed"
-
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
-
- if [[ ${PV} = *9999* ]]; then
- # virt-manager's autogen.sh touches this and eautoreconf fails
- # unless we do this
- touch config.rpath
-
- rm -rf config.status || die
- intltoolize --automake --copy --force || die
- perl -i -p -e 's,^DATADIRNAME.*$,DATADIRNAME = share,' po/Makefile.in.in || die
- perl -i -p -e 's,^GETTEXT_PACKAGE.*$,GETTEXT_PACKAGE = virt-manager,' \
- po/Makefile.in.in || die
- eautoreconf
- fi
-
- gnome2_src_prepare
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/share/${PN}
- gnome2_pkg_postinst
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/share/${PN}
- gnome2_pkg_postrm
-}