summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-06-10 22:39:15 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-06-10 22:39:15 +0000
commit9d21370b09cddb07eebb820dbf2274977f42550b (patch)
tree9306bedef163d74c8d92931d4c1bc255f5cf186d /app-emulation
parentNew upstream version. Removed Carlos from metadata.xml as he requested. Remov... (diff)
downloadgentoo-2-9d21370b09cddb07eebb820dbf2274977f42550b.tar.gz
gentoo-2-9d21370b09cddb07eebb820dbf2274977f42550b.tar.bz2
gentoo-2-9d21370b09cddb07eebb820dbf2274977f42550b.zip
Fixed to compile properly on amd64 with eselect-compiler. Closes bug #128772.
(Portage version: 2.1_rc4-r4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/wine-0.9.10.ebuild12
-rw-r--r--app-emulation/wine/wine-0.9.15.ebuild21
3 files changed, 31 insertions, 8 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 3c1aa857ce91..c5bfb7dc48fa 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.143 2006/06/09 05:16:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.144 2006/06/10 22:39:15 eradicator Exp $
+
+ 10 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org> wine-0.9.10.ebuild,
+ wine-0.9.15.ebuild:
+ Fixed to compile properly on amd64 with eselect-compiler. Closes bug #128772.
*wine-0.9.15 (09 Jun 2006)
diff --git a/app-emulation/wine/wine-0.9.10.ebuild b/app-emulation/wine/wine-0.9.10.ebuild
index dfe03f6b30b8..dcd55ee019d9 100644
--- a/app-emulation/wine/wine-0.9.10.ebuild
+++ b/app-emulation/wine/wine-0.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.10.ebuild,v 1.3 2006/04/09 17:49:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.10.ebuild,v 1.4 2006/06/10 22:39:15 eradicator Exp $
inherit eutils flag-o-matic multilib
@@ -60,7 +60,15 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- use amd64 && has_multilib_profile && export ABI=x86
+ if use amd64 ; then
+ has_multilib_profile || die "Your profile does not support compilation of wine."
+
+ export ABI=x86
+ if has_version app-admin/eselect-compiler ; then
+ CHOST=$(get_abi_CHOST ${ABI})
+ CBUILD=${CHOST}
+ fi
+ fi
}
src_unpack() {
diff --git a/app-emulation/wine/wine-0.9.15.ebuild b/app-emulation/wine/wine-0.9.15.ebuild
index 28c3e710f897..1de833f11dfe 100644
--- a/app-emulation/wine/wine-0.9.15.ebuild
+++ b/app-emulation/wine/wine-0.9.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.15.ebuild,v 1.1 2006/06/09 05:16:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.15.ebuild,v 1.2 2006/06/10 22:39:15 eradicator Exp $
inherit eutils flag-o-matic multilib
@@ -56,12 +56,10 @@ DEPEND="${RDEPEND}
virtual/x11
)
)
+ amd64? ( app-admin/eselect-compiler )
sys-devel/bison
sys-devel/flex"
-# this will not build as 64bit code
-export ABI=x86
-
src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
@@ -104,9 +102,22 @@ src_compile() {
strip-flags
+ if use amd64 ; then
+ # If we don't want --enable-win64, then we need override the
+ # toolchain. If we do --enable-win64, then configure takes
+ # care of it for us
+
+ export CHOST="i686-pc-linux-gnu"
+ export CBUILD="${CHOST}"
+
+ # This should be handled by eselect-binutils in the future:
+ export LD="$(tc-getLD) -m elf_i386"
+ export AS="$(tc-getAS) --32"
+ fi
+
# $(use_enable amd64 win64)
econf \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
--sysconfdir=/etc/wine \
$(use_with ncurses curses) \
$(use_with opengl) \