summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-07 13:27:17 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-07 13:27:17 +0000
commitbb0ee13ef08327711ff78042ca41e797feb64422 (patch)
tree84b3a1b8175ee8636247d846d3c09f36e00c551d /app-emulation
parentAdd patch to build with latest ffmpeg/libav just like for k9copy. (diff)
downloadgentoo-2-bb0ee13ef08327711ff78042ca41e797feb64422.tar.gz
gentoo-2-bb0ee13ef08327711ff78042ca41e797feb64422.tar.bz2
gentoo-2-bb0ee13ef08327711ff78042ca41e797feb64422.zip
Version bump #376107 by Andreas Sturmlechner.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/wine-1.3.25.ebuild201
-rw-r--r--app-emulation/wine/wine-1.3.26.ebuild201
3 files changed, 410 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 0ac7d62c4b07..7706170643ec 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.376 2011/08/07 13:25:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.377 2011/08/07 13:27:17 vapier Exp $
+
+*wine-1.3.26 (07 Aug 2011)
+*wine-1.3.25 (07 Aug 2011)
+
+ 07 Aug 2011; Mike Frysinger <vapier@gentoo.org> +wine-1.3.25.ebuild,
+ +wine-1.3.26.ebuild:
+ Version bump #376107 by Andreas Sturmlechner.
07 Aug 2011; Mike Frysinger <vapier@gentoo.org> wine-9999.ebuild:
Drop USE="esd jack nas" to match upstream, and drop USE=pulseaudio as it
diff --git a/app-emulation/wine/wine-1.3.25.ebuild b/app-emulation/wine/wine-1.3.25.ebuild
new file mode 100644
index 000000000000..ab2faf9986d4
--- /dev/null
+++ b/app-emulation/wine/wine-1.3.25.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.25.ebuild,v 1.1 2011/08/07 13:27:17 vapier Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
+ inherit git-2 autotools
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ AUTOTOOLS_AUTO_DEPEND="no"
+ inherit autotools
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+fi
+
+GV="1.2.0"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.org/"
+SRC_URI="${SRC_URI}
+ gecko? (
+ mirror://sourceforge/wine/wine_gecko-${GV}-x86.msi
+ win64? ( mirror://sourceforge/wine/wine_gecko-${GV}-x86_64.msi )
+ )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="alsa capi cups custom-cflags dbus fontconfig +gecko gnutls gphoto2 gsm gstreamer hal jpeg lcms ldap mp3 ncurses nls openal opencl +opengl +oss +perl png samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+RESTRICT="test" #72375
+
+MLIB_DEPS="amd64? (
+ truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ X? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ openal? ( app-emulation/emul-linux-x86-sdl )
+ opengl? ( app-emulation/emul-linux-x86-opengl )
+ v4l? ( app-emulation/emul-linux-x86-medialibs )
+ app-emulation/emul-linux-x86-baselibs
+ >=sys-kernel/linux-headers-2.6
+ )"
+RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
+ perl? ( dev-lang/perl dev-perl/XML-Simple )
+ capi? ( net-dialup/capi4k-utils )
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ fontconfig? ( media-libs/fontconfig )
+ gphoto2? ( media-libs/libgphoto2 )
+ openal? ( media-libs/openal )
+ dbus? ( sys-apps/dbus )
+ gnutls? ( net-libs/gnutls )
+ gstreamer? ( media-libs/gstreamer media-libs/gst-plugins-base )
+ hal? ( sys-apps/hal )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ xinerama? ( x11-libs/libXinerama )
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ opencl? ( x11-drivers/nvidia-drivers >=dev-util/nvidia-cuda-toolkit-3.1 )
+ opengl? ( virtual/opengl )
+ gsm? ( media-sound/gsm )
+ jpeg? ( virtual/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( =media-libs/lcms-1* )
+ mp3? ( >=media-sound/mpg123-1.5.0 )
+ nls? ( sys-devel/gettext )
+ samba? ( >=net-fs/samba-3.0.25 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ scanner? ( media-gfx/sane-backends )
+ ssl? ( dev-libs/openssl )
+ png? ( media-libs/libpng )
+ v4l? ( media-libs/libv4l )
+ !win64? ( ${MLIB_DEPS} )
+ win32? ( ${MLIB_DEPS} )
+ xcomposite? ( x11-libs/libXcomposite ) "
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ if use win64 ; then
+ [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
+ && die "you need gcc-4.4+ to build 64bit wine"
+ fi
+
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ unpack ${MY_P}.tar.bz2
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
+ epatch_user #282735
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+do_configure() {
+ local builddir="${WORKDIR}/wine$1"
+ mkdir -p "${builddir}"
+ pushd "${builddir}" >/dev/null
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with alsa) \
+ $(use_with capi) \
+ $(use_with lcms cms) \
+ $(use_with cups) \
+ $(use_with ncurses curses) \
+ $(use_with fontconfig) \
+ $(use_with gnutls) \
+ $(use_with gphoto2 gphoto) \
+ $(use_with gsm) \
+ $(use_with gstreamer) \
+ $(! use dbus && echo --without-hal || use_with hal) \
+ $(use_with jpeg) \
+ $(use_with ldap) \
+ $(use_with mp3 mpg123) \
+ $(use_with nls gettextpo) \
+ $(use_with openal) \
+ $(use_with opencl) \
+ $(use_with opengl) \
+ $(use_with ssl openssl) \
+ $(use_with oss) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with scanner sane) \
+ $(use_enable test tests) \
+ $(use_with truetype freetype) \
+ $(use_with v4l) \
+ $(use_with X x) \
+ $(use_with xcomposite) \
+ $(use_with xinerama) \
+ $(use_with xml) \
+ $(use_with xml xslt) \
+ $2
+
+ emake -j1 depend || die "depend"
+
+ popd >/dev/null
+}
+src_configure() {
+ export LDCONFIG=/bin/true
+ use custom-cflags || strip-flags
+
+ if use win64 ; then
+ do_configure 64 --enable-win64
+ use win32 && ABI=x86 do_configure 32 --with-wine64=../wine64
+ else
+ ABI=x86 do_configure 32 --disable-win64
+ fi
+}
+
+src_compile() {
+ local b
+ for b in 64 32 ; do
+ local builddir="${WORKDIR}/wine${b}"
+ [[ -d ${builddir} ]] || continue
+ emake -C "${builddir}" all || die
+ done
+}
+
+src_install() {
+ local b
+ for b in 64 32 ; do
+ local builddir="${WORKDIR}/wine${b}"
+ [[ -d ${builddir} ]] || continue
+ emake -C "${builddir}" install DESTDIR="${D}" || die
+ done
+ dodoc ANNOUNCE AUTHORS README
+ if use gecko ; then
+ insinto /usr/share/wine/gecko
+ doins "${DISTDIR}"/wine_gecko-${GV}-x86.msi || die
+ use win64 && { doins "${DISTDIR}"/wine_gecko-${GV}-x86_64.msi || die ; }
+ fi
+ if ! use perl ; then
+ rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die
+ fi
+}
+
+pkg_postinst() {
+ paxctl -psmr "${ROOT}"/usr/bin/wine{,-preloader} 2>/dev/null #255055
+}
diff --git a/app-emulation/wine/wine-1.3.26.ebuild b/app-emulation/wine/wine-1.3.26.ebuild
new file mode 100644
index 000000000000..f99d8a9a9721
--- /dev/null
+++ b/app-emulation/wine/wine-1.3.26.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.26.ebuild,v 1.1 2011/08/07 13:27:17 vapier Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
+ inherit git-2 autotools
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ AUTOTOOLS_AUTO_DEPEND="no"
+ inherit autotools
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+fi
+
+GV="1.2.0"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.org/"
+SRC_URI="${SRC_URI}
+ gecko? (
+ mirror://sourceforge/wine/wine_gecko-${GV}-x86.msi
+ win64? ( mirror://sourceforge/wine/wine_gecko-${GV}-x86_64.msi )
+ )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="alsa capi cups custom-cflags dbus fontconfig +gecko gnutls gphoto2 gsm gstreamer hal jpeg lcms ldap mp3 ncurses nls openal opencl +opengl +oss +perl png samba scanner ssl test +threads +truetype v4l +win32 +win64 +X xcomposite xinerama xml"
+RESTRICT="test" #72375
+
+MLIB_DEPS="amd64? (
+ truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ X? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ openal? ( app-emulation/emul-linux-x86-sdl )
+ opengl? ( app-emulation/emul-linux-x86-opengl )
+ v4l? ( app-emulation/emul-linux-x86-medialibs )
+ app-emulation/emul-linux-x86-baselibs
+ >=sys-kernel/linux-headers-2.6
+ )"
+RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
+ perl? ( dev-lang/perl dev-perl/XML-Simple )
+ capi? ( net-dialup/capi4k-utils )
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ fontconfig? ( media-libs/fontconfig )
+ gphoto2? ( media-libs/libgphoto2 )
+ openal? ( media-libs/openal )
+ dbus? ( sys-apps/dbus )
+ gnutls? ( net-libs/gnutls )
+ gstreamer? ( media-libs/gstreamer media-libs/gst-plugins-base )
+ hal? ( sys-apps/hal )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ xinerama? ( x11-libs/libXinerama )
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ opencl? ( x11-drivers/nvidia-drivers >=dev-util/nvidia-cuda-toolkit-3.1 )
+ opengl? ( virtual/opengl )
+ gsm? ( media-sound/gsm )
+ jpeg? ( virtual/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( =media-libs/lcms-1* )
+ mp3? ( >=media-sound/mpg123-1.5.0 )
+ nls? ( sys-devel/gettext )
+ samba? ( >=net-fs/samba-3.0.25 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ scanner? ( media-gfx/sane-backends )
+ ssl? ( dev-libs/openssl )
+ png? ( media-libs/libpng )
+ v4l? ( media-libs/libv4l )
+ !win64? ( ${MLIB_DEPS} )
+ win32? ( ${MLIB_DEPS} )
+ xcomposite? ( x11-libs/libXcomposite ) "
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ if use win64 ; then
+ [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
+ && die "you need gcc-4.4+ to build 64bit wine"
+ fi
+
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ unpack ${MY_P}.tar.bz2
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
+ epatch_user #282735
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+do_configure() {
+ local builddir="${WORKDIR}/wine$1"
+ mkdir -p "${builddir}"
+ pushd "${builddir}" >/dev/null
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with alsa) \
+ $(use_with capi) \
+ $(use_with lcms cms) \
+ $(use_with cups) \
+ $(use_with ncurses curses) \
+ $(use_with fontconfig) \
+ $(use_with gnutls) \
+ $(use_with gphoto2 gphoto) \
+ $(use_with gsm) \
+ $(use_with gstreamer) \
+ $(! use dbus && echo --without-hal || use_with hal) \
+ $(use_with jpeg) \
+ $(use_with ldap) \
+ $(use_with mp3 mpg123) \
+ $(use_with nls gettextpo) \
+ $(use_with openal) \
+ $(use_with opencl) \
+ $(use_with opengl) \
+ $(use_with ssl openssl) \
+ $(use_with oss) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with scanner sane) \
+ $(use_enable test tests) \
+ $(use_with truetype freetype) \
+ $(use_with v4l) \
+ $(use_with X x) \
+ $(use_with xcomposite) \
+ $(use_with xinerama) \
+ $(use_with xml) \
+ $(use_with xml xslt) \
+ $2
+
+ emake -j1 depend || die "depend"
+
+ popd >/dev/null
+}
+src_configure() {
+ export LDCONFIG=/bin/true
+ use custom-cflags || strip-flags
+
+ if use win64 ; then
+ do_configure 64 --enable-win64
+ use win32 && ABI=x86 do_configure 32 --with-wine64=../wine64
+ else
+ ABI=x86 do_configure 32 --disable-win64
+ fi
+}
+
+src_compile() {
+ local b
+ for b in 64 32 ; do
+ local builddir="${WORKDIR}/wine${b}"
+ [[ -d ${builddir} ]] || continue
+ emake -C "${builddir}" all || die
+ done
+}
+
+src_install() {
+ local b
+ for b in 64 32 ; do
+ local builddir="${WORKDIR}/wine${b}"
+ [[ -d ${builddir} ]] || continue
+ emake -C "${builddir}" install DESTDIR="${D}" || die
+ done
+ dodoc ANNOUNCE AUTHORS README
+ if use gecko ; then
+ insinto /usr/share/wine/gecko
+ doins "${DISTDIR}"/wine_gecko-${GV}-x86.msi || die
+ use win64 && { doins "${DISTDIR}"/wine_gecko-${GV}-x86_64.msi || die ; }
+ fi
+ if ! use perl ; then
+ rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die
+ fi
+}
+
+pkg_postinst() {
+ paxctl -psmr "${ROOT}"/usr/bin/wine{,-preloader} 2>/dev/null #255055
+}