summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-12-09 15:24:28 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-12-09 15:24:28 +0000
commitcd9a0765c92366f89ef5ef22be703061a590e935 (patch)
treeba3fbf06355d11a2ad7c1b8a2e890f29b546d398 /app-emulation
parentversion bump (diff)
downloadgentoo-2-cd9a0765c92366f89ef5ef22be703061a590e935.tar.gz
gentoo-2-cd9a0765c92366f89ef5ef22be703061a590e935.tar.bz2
gentoo-2-cd9a0765c92366f89ef5ef22be703061a590e935.zip
Michal Privoznik <mprivozn@redhat.com> pointed out that the live ebuild
was broken and the deps for 0.10.0-r1 were wrong as well. This should hopefully fix both. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virt-manager/ChangeLog8
-rw-r--r--app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild5
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild48
3 files changed, 34 insertions, 27 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index c48506c6fdae..a6f5e5fa04a3 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.97 2013/12/02 22:46:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.98 2013/12/09 15:24:28 cardoe Exp $
+
+ 09 Dec 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0-r1.ebuild,
+ virt-manager-9999.ebuild:
+ Michal Privoznik <mprivozn@redhat.com> pointed out that the live ebuild was
+ broken and the deps for 0.10.0-r1 were wrong as well. This should hopefully
+ fix both.
02 Dec 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0-r1.ebuild,
virt-manager-0.10.0.ebuild:
diff --git a/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild b/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild
index 67c95b86d6c3..9b63229770d8 100644
--- a/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild
+++ b/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild,v 1.4 2013/12/02 22:46:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0-r1.ebuild,v 1.5 2013/12/09 15:24:28 cardoe Exp $
EAPI=5
@@ -18,6 +18,7 @@ if [[ ${PV} = *9999* ]]; then
inherit git-2
SRC_URI=""
KEYWORDS=""
+ EGIT_REPO_URI="git://git.fedorahosted.org/virt-manager.git"
else
SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
${BACKPORTS+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
@@ -32,7 +33,7 @@ RDEPEND="!app-emulation/virtinst
x11-libs/gtk+:3[introspection]
|| (
dev-python/libvirt-python[${PYTHON_USEDEP}]
- >=app-emulation/libvirt-0.7.0[python,${PYTHON_USEDEP}]
+ >=app-emulation/libvirt-0.7.0[python(-),${PYTHON_USEDEP}]
)
>=app-emulation/libvirt-glib-0.0.9[introspection,python,${PYTHON_USEDEP}]
${PYTHON_DEPS}
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index 0a7489f22c4a..8f09441d1bea 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.18 2013/09/25 07:24:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.19 2013/12/09 15:24:28 cardoe Exp $
EAPI=5
-#BACKPORTS=
+BACKPORTS=1cd29748
PYTHON_COMPAT=( python{2_6,2_7} )
DISTUTILS_SINGLE_IMPL=1
-inherit eutils gnome2 distutils-r1
+inherit gnome2 distutils-r1
DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="http://virt-manager.org"
@@ -18,6 +18,7 @@ if [[ ${PV} = *9999* ]]; then
inherit git-2
SRC_URI=""
KEYWORDS=""
+ EGIT_REPO_URI="git://git.fedorahosted.org/virt-manager.git"
else
SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
${BACKPORTS+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
@@ -26,50 +27,49 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="gnome-keyring policykit sasl +spice +vnc"
+IUSE="gnome-keyring policykit sasl"
RDEPEND="!app-emulation/virtinst
x11-libs/gtk+:3[introspection]
- >=app-emulation/libvirt-0.7.0[python]
- >=app-emulation/libvirt-glib-0.0.9
+ || (
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ >=app-emulation/libvirt-0.7.0[python(-),${PYTHON_USEDEP}]
+ )
+ >=app-emulation/libvirt-glib-0.0.9[introspection,python,${PYTHON_USEDEP}]
${PYTHON_DEPS}
dev-libs/libxml2[python,${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/urlgrabber[${PYTHON_USEDEP}]
+ gnome-base/dconf
+ >=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}]
+ net-misc/spice-gtk[gtk3,introspection,python,sasl?,${PYTHON_USEDEP}]
x11-libs/vte:2.90[introspection]
gnome-keyring? ( dev-python/gnome-keyring-python )
- policykit? ( sys-auth/polkit )
- spice? ( net-misc/spice-gtk[gtk3,introspection,python,sasl?] )
- vnc? ( >=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}] )"
+ policykit? ( sys-auth/polkit[introspection] )"
DEPEND="${RDEPEND}
dev-lang/perl
dev-util/intltool"
DOCS=( README NEWS )
-python_prepare_all() {
- epatch_user
- distutils-r1_python_prepare_all
-}
-
distutils-r1_python_compile() {
local defgraphics=
- use vnc && defgraphics="vnc"
- use spice && defgraphics="spice"
-
esetup.py configure \
--qemu-user=qemu \
- --default-graphics=${defgraphics}
+ --default-graphics=spice
}
python_install_all() {
- python_fix_shebang "${ED}/usr/share/virt-manager/virt-clone"
- python_fix_shebang "${ED}/usr/share/virt-manager/virt-convert"
- python_fix_shebang "${ED}/usr/share/virt-manager/virt-image"
- python_fix_shebang "${ED}/usr/share/virt-manager/virt-install"
- python_fix_shebang "${ED}/usr/share/virt-manager/virt-manager"
-
distutils-r1_python_install_all
+ python_fix_shebang \
+ "${ED}"/usr/share/virt-manager/virt-{clone,convert,image,install,manager}
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ cd "${ED}"
+ export GNOME2_ECLASS_ICONS=$(find 'usr/share/virt-manager/icons' -maxdepth 1 -mindepth 1 -type d 2> /dev/null)
}