summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-11-03 02:30:29 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-11-03 02:30:29 +0000
commit92fac3ef326d7767cc01a2be4213fbc6f5ff0557 (patch)
tree8394bc379b7601e67ce8407834e64043f2a3d859 /app-forensics/aide
parentRemove portage-2.2 mask now that it isn't masked in gx86 (diff)
downloadgentoo-2-92fac3ef326d7767cc01a2be4213fbc6f5ff0557.tar.gz
gentoo-2-92fac3ef326d7767cc01a2be4213fbc6f5ff0557.tar.bz2
gentoo-2-92fac3ef326d7767cc01a2be4213fbc6f5ff0557.zip
Fixed USE flags conflicts, bug #343221.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/aide')
-rw-r--r--app-forensics/aide/ChangeLog7
-rw-r--r--app-forensics/aide/aide-0.13.1-r3.ebuild4
-rw-r--r--app-forensics/aide/aide-0.13.1-r5.ebuild4
-rw-r--r--app-forensics/aide/aide-0.13.1.ebuild4
-rw-r--r--app-forensics/aide/aide-0.14-r1.ebuild133
-rw-r--r--app-forensics/aide/aide-0.14.2.ebuild6
-rw-r--r--app-forensics/aide/aide-0.15.1.ebuild6
7 files changed, 18 insertions, 146 deletions
diff --git a/app-forensics/aide/ChangeLog b/app-forensics/aide/ChangeLog
index 3fb03112a77d..87ad6734f623 100644
--- a/app-forensics/aide/ChangeLog
+++ b/app-forensics/aide/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/aide
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.52 2010/10/27 16:45:29 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/ChangeLog,v 1.53 2010/11/03 02:30:28 matsuu Exp $
+
+ 03 Nov 2010; MATSUU Takuto <matsuu@gentoo.org> aide-0.13.1.ebuild,
+ aide-0.13.1-r3.ebuild, aide-0.13.1-r5.ebuild, -aide-0.14-r1.ebuild,
+ aide-0.14.2.ebuild, aide-0.15.1.ebuild:
+ Fixed USE flags conflicts, bug #343221.
*aide-0.15.1 (27 Oct 2010)
diff --git a/app-forensics/aide/aide-0.13.1-r3.ebuild b/app-forensics/aide/aide-0.13.1-r3.ebuild
index 02e9b992ed41..90d7b11f996e 100644
--- a/app-forensics/aide/aide-0.13.1-r3.ebuild
+++ b/app-forensics/aide/aide-0.13.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.13.1-r3.ebuild,v 1.6 2010/07/11 11:13:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.13.1-r3.ebuild,v 1.7 2010/11/03 02:30:28 matsuu Exp $
inherit autotools eutils
@@ -35,7 +35,7 @@ DEPEND="${DEPEND}
sys-devel/bison
sys-devel/flex"
-pkg_config() {
+pkg_setup() {
if use mhash && use postgres ; then
eerror "We cannot emerge aide with mhash and postgres USE flags at the same time."
eerror "Please remove mhash OR postgres USE flags."
diff --git a/app-forensics/aide/aide-0.13.1-r5.ebuild b/app-forensics/aide/aide-0.13.1-r5.ebuild
index 9deb28bd3037..688e8512ecd8 100644
--- a/app-forensics/aide/aide-0.13.1-r5.ebuild
+++ b/app-forensics/aide/aide-0.13.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.13.1-r5.ebuild,v 1.3 2010/07/11 11:13:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.13.1-r5.ebuild,v 1.4 2010/11/03 02:30:28 matsuu Exp $
inherit autotools eutils
@@ -35,7 +35,7 @@ DEPEND="${DEPEND}
sys-devel/bison
sys-devel/flex"
-pkg_config() {
+pkg_setup() {
if use mhash && use postgres ; then
eerror "We cannot emerge aide with mhash and postgres USE flags at the same time."
eerror "Please remove mhash OR postgres USE flags."
diff --git a/app-forensics/aide/aide-0.13.1.ebuild b/app-forensics/aide/aide-0.13.1.ebuild
index 679124794c44..8aa48c4764db 100644
--- a/app-forensics/aide/aide-0.13.1.ebuild
+++ b/app-forensics/aide/aide-0.13.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.13.1.ebuild,v 1.12 2010/07/11 11:13:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.13.1.ebuild,v 1.13 2010/11/03 02:30:28 matsuu Exp $
WANT_AUTOCONF='latest'
WANT_AUTOMAKE='latest'
inherit eutils autotools
@@ -34,7 +34,7 @@ DEPEND="${DEPEND}
sys-devel/bison
sys-devel/flex"
-pkg_config() {
+pkg_setup() {
if use mhash && use postgres ; then
eerror "We cannot emerge aide with mhash and postgres USE flags at the same time."
eerror "Please remove mhash OR postgres USE flags."
diff --git a/app-forensics/aide/aide-0.14-r1.ebuild b/app-forensics/aide/aide-0.14-r1.ebuild
deleted file mode 100644
index 16d373deaed7..000000000000
--- a/app-forensics/aide/aide-0.14-r1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.14-r1.ebuild,v 1.3 2010/07/11 11:13:03 armin76 Exp $
-
-EAPI="3"
-
-inherit autotools confutils eutils
-
-DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a replacement for Tripwire"
-HOMEPAGE="http://aide.sourceforge.net/"
-SRC_URI="mirror://sourceforge/aide/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="acl audit curl mhash nls postgres selinux static xattr zlib"
-#IUSE="acl audit curl mhash nls postgres prelink selinux static xattr zlib"
-
-# libsandbox: Can't dlopen libc: (null)
-#RESTRICT="test"
-
-DEPEND="acl? ( virtual/acl )
- audit? ( sys-process/audit )
- curl? ( net-misc/curl )
- mhash? ( >=app-crypt/mhash-0.9.2 )
- !mhash? ( dev-libs/libgcrypt )
- nls? ( virtual/libintl )
- postgres? ( dev-db/postgresql-base )
- selinux? ( sys-libs/libselinux )
- xattr? ( sys-apps/attr )
- zlib? ( sys-libs/zlib )"
-# prelink? ( sys-devel/prelink )
-
-RDEPEND="!static? ( ${DEPEND} )"
-
-DEPEND="${DEPEND}
- nls? ( sys-devel/gettext )
- sys-devel/bison
- sys-devel/flex"
-
-pkg_config() {
- confutils_use_conflict mhash postgres
- confutils_use_conflict curl static
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-gentoo.patch"
-
- # fix libgcrypt issue, bug #266175
- epatch "${FILESDIR}/${PN}-0.13.1-libgrypt_init.patch"
-
- # fix as-need issue, bug #271326
- epatch "${FILESDIR}/${P}-as-needed.patch"
-
- # fix zlib issue, bug #316665
- epatch "${FILESDIR}/${PN}-0.13.1-zlib.patch"
-
- # fix configure issue, bug #323187
- epatch "${FILESDIR}/${P}-configure.patch"
-
- if ! use selinux ; then
- sed -i -e 's/\+selinux//' doc/aide.conf.in || die
- fi
-
- if ! use xattr ; then
- sed -i -e 's/\+xattrs//' doc/aide.conf.in || die
- fi
-
- if ! use acl ; then
- sed -i -e 's/\+acl//' doc/aide.conf.in || die
- fi
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with acl posix-acl) \
- $(use_with audit) \
- $(use_with curl) \
- $(use_with !mhash gcrypt) \
- $(use_with mhash mhash) \
- $(use_with nls locale) \
- $(use_with postgres psql) \
- $(use_with selinux) \
- $(use_enable static) \
- $(use_with xattr) \
- $(use_with zlib) \
- --sysconfdir="${EPREFIX}/etc/aide" || die "econf failed"
-# $(use_with prelink)
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-man || die "emake install failed"
-
- keepdir /var/lib/aide || die
- fowners root:0 /var/lib/aide || die
- fperms 0755 /var/lib/aide || die
-
- keepdir /var/log/aide || die
-
- insinto /etc/aide
- doins "${FILESDIR}"/aide.conf || die
-
- dosbin "${FILESDIR}"/aideinit || die
-
- dodoc ChangeLog AUTHORS NEWS README "${FILESDIR}"/aide.cron || die
- dohtml doc/manual.html || die
-}
-
-pkg_postinst() {
- elog
- elog "A sample configuration file has been installed as"
- elog "/etc/aide/aide.conf. Please edit to meet your needs."
- elog "Read the aide.conf(5) manual page for more information."
- elog "A helper script, aideinit, has been installed and can"
- elog "be used to make AIDE management easier. Please run"
- elog "aideinit --help for more information"
- elog
-
- if use postgres; then
- elog "Due to a bad assumption by aide, you must issue the following"
- elog "command after the database initialization (aide --init ...):"
- elog
- elog 'psql -c "update pg_index set indisunique=false from pg_class \\ '
- elog " where pg_class.relname='TABLE_pkey' and \ "
- elog ' pg_class.oid=pg_index.indexrelid" -h HOSTNAME -p PORT DBASE USER'
- elog
- elog "where TABLE, HOSTNAME, PORT, DBASE, and USER are the same as"
- elog "your aide.conf."
- elog
- fi
-}
diff --git a/app-forensics/aide/aide-0.14.2.ebuild b/app-forensics/aide/aide-0.14.2.ebuild
index 202dff3743d5..d5f4b0137679 100644
--- a/app-forensics/aide/aide-0.14.2.ebuild
+++ b/app-forensics/aide/aide-0.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.14.2.ebuild,v 1.2 2010/07/11 11:13:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.14.2.ebuild,v 1.3 2010/11/03 02:30:28 matsuu Exp $
EAPI="3"
@@ -34,9 +34,9 @@ DEPEND="${DEPEND}
sys-devel/bison
sys-devel/flex"
-pkg_config() {
+pkg_setup() {
confutils_use_conflict mhash postgres
- confutils_use_conflict curl static
+ confutils_use_conflict static curl postgres
}
src_prepare() {
diff --git a/app-forensics/aide/aide-0.15.1.ebuild b/app-forensics/aide/aide-0.15.1.ebuild
index 3b3e8d74bd3b..1e16140a5c21 100644
--- a/app-forensics/aide/aide-0.15.1.ebuild
+++ b/app-forensics/aide/aide-0.15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.15.1.ebuild,v 1.1 2010/10/27 16:45:29 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/aide/aide-0.15.1.ebuild,v 1.2 2010/11/03 02:30:28 matsuu Exp $
EAPI="3"
@@ -34,9 +34,9 @@ DEPEND="${DEPEND}
sys-devel/bison
sys-devel/flex"
-pkg_config() {
+pkg_setup() {
confutils_use_conflict mhash postgres
- confutils_use_conflict curl static
+ confutils_use_conflict static curl postgres
}
src_prepare() {