summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-06 14:32:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-06 14:32:11 +0000
commit498825643144f2c45f5cd3971641b69a4bc7497a (patch)
tree64a6417beaa89c44ad371dc43fa8dc830bbcc839 /app-forensics
parentAdd keditfiletype in 4.2.4 version and konqueror in 4.3.0 in RDEPEND of dolph... (diff)
downloadgentoo-2-498825643144f2c45f5cd3971641b69a4bc7497a.tar.gz
gentoo-2-498825643144f2c45f5cd3971641b69a4bc7497a.tar.bz2
gentoo-2-498825643144f2c45f5cd3971641b69a4bc7497a.zip
Fix building with GLIBC 2.10+ wrt #272878.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/ChangeLog6
-rw-r--r--app-forensics/afflib/afflib-3.3.4.ebuild8
-rw-r--r--app-forensics/afflib/files/afflib-3.3.4-glibc-2.10.patch22
3 files changed, 34 insertions, 2 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
index 698b33fbf29b..8255e9ae95ed 100644
--- a/app-forensics/afflib/ChangeLog
+++ b/app-forensics/afflib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-forensics/afflib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.5 2009/05/01 19:02:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.6 2009/08/06 14:32:11 ssuominen Exp $
+
+ 06 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> afflib-3.3.4.ebuild,
+ +files/afflib-3.3.4-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #272878.
01 May 2009; Raúl Porcel <armin76@gentoo.org> afflib-3.3.4.ebuild:
Add ~arm/~s390 wrt #203758
diff --git a/app-forensics/afflib/afflib-3.3.4.ebuild b/app-forensics/afflib/afflib-3.3.4.ebuild
index 8b6379c07edd..dc7e4f90b102 100644
--- a/app-forensics/afflib/afflib-3.3.4.ebuild
+++ b/app-forensics/afflib/afflib-3.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.3.4.ebuild,v 1.5 2009/05/01 19:02:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.3.4.ebuild,v 1.6 2009/08/06 14:32:11 ssuominen Exp $
inherit eutils
@@ -24,6 +24,12 @@ DEPEND="
dev-libs/openssl"
RDEPEND=${DEPEND}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
src_compile() {
econf \
$(use_enable fuse) \
diff --git a/app-forensics/afflib/files/afflib-3.3.4-glibc-2.10.patch b/app-forensics/afflib/files/afflib-3.3.4-glibc-2.10.patch
new file mode 100644
index 000000000000..b3ea15caed8c
--- /dev/null
+++ b/app-forensics/afflib/files/afflib-3.3.4-glibc-2.10.patch
@@ -0,0 +1,22 @@
+diff -up afflib-3.3.4/tools/afverify.cpp.gcc44 afflib-3.3.4/tools/afverify.cpp
+--- afflib-3.3.4/tools/afverify.cpp.gcc44 2008-07-21 06:25:29.000000000 +0200
++++ afflib-3.3.4/tools/afverify.cpp 2009-03-02 12:48:59.000000000 +0100
+@@ -240,12 +240,16 @@ string get_xml_field(const char *buf,con
+ int verify_bom_signature(AFFILE *af,const char *buf)
+ {
+ const char *cce = "</" AF_XML_AFFBOM ">\n";
+- char *chain_end = strstr(buf,cce);
++ char *buf_tmp;
++ char *cce_tmp;
++ strcpy(buf_tmp, buf);
++ strcpy(cce_tmp, cce);
++ char *chain_end = strstr(buf_tmp,cce_tmp);
+ if(!chain_end){
+ warn("end of chain XML can't be found\n");
+ return -1; // can't find it
+ }
+- char *sig_start = chain_end + strlen(cce);
++ char *sig_start = chain_end + strlen(cce_tmp);
+
+ BIO *seg = BIO_new_mem_buf((void *)buf,strlen(buf));
+ BIO_seek(seg,0);