summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2014-12-10 00:36:21 +0000
committerHanno Böck <hanno@gentoo.org>2014-12-10 00:36:21 +0000
commitce623c71b326449f6ee4c3de8065dce46da1f7d1 (patch)
tree68ccb4384a5fa80b2c7233bd080f26c18f98485d /app-forensics
parentremove obsolete mask for app-emulation/virtinst (diff)
downloadgentoo-2-ce623c71b326449f6ee4c3de8065dce46da1f7d1.tar.gz
gentoo-2-ce623c71b326449f6ee4c3de8065dce46da1f7d1.tar.bz2
gentoo-2-ce623c71b326449f6ee4c3de8065dce46da1f7d1.zip
afl bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BBB51E42)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afl/ChangeLog7
-rw-r--r--app-forensics/afl/afl-0.89b.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-forensics/afl/ChangeLog b/app-forensics/afl/ChangeLog
index 5f6dae0ea39f..67fc3f64d40e 100644
--- a/app-forensics/afl/ChangeLog
+++ b/app-forensics/afl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/ChangeLog,v 1.3 2014/11/27 23:00:17 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/ChangeLog,v 1.4 2014/12/10 00:36:21 hanno Exp $
+
+*afl-0.89b (10 Dec 2014)
+
+ 10 Dec 2014; <hanno@gentoo.org> +afl-0.89b.ebuild:
+ Bump.
*afl-0.74b (27 Nov 2014)
diff --git a/app-forensics/afl/afl-0.89b.ebuild b/app-forensics/afl/afl-0.89b.ebuild
new file mode 100644
index 000000000000..4d0852d9bfc1
--- /dev/null
+++ b/app-forensics/afl/afl-0.89b.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/afl-0.89b.ebuild,v 1.1 2014/12/10 00:36:21 hanno Exp $
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="american fuzzy lop - compile-time instrumentation fuzzer"
+HOMEPAGE="http://lcamtuf.coredump.cx/afl/"
+SRC_URI="http://lcamtuf.coredump.cx/afl/releases//${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="sys-devel/gcc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ HELPER_PATH="/usr/$(get_libdir)/afl"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ HELPER_PATH="/usr/$(get_libdir)/afl" \
+ DOC_PATH="/usr/share/doc/${PF}" \
+ install
+}