summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-11-24 15:41:28 +0000
committerMamoru Komachi <usata@gentoo.org>2003-11-24 15:41:28 +0000
commit358b5e84834ee92247d81be5593ec150e9ada875 (patch)
treeafbff67723a7e4eafee7dcf153a914e70a6c5764 /app-i18n/anthy-ss/anthy-ss-4723.ebuild
parentNew CVS snapshot (diff)
downloadgentoo-2-358b5e84834ee92247d81be5593ec150e9ada875.tar.gz
gentoo-2-358b5e84834ee92247d81be5593ec150e9ada875.tar.bz2
gentoo-2-358b5e84834ee92247d81be5593ec150e9ada875.zip
New CVS snapshot
Diffstat (limited to 'app-i18n/anthy-ss/anthy-ss-4723.ebuild')
-rw-r--r--app-i18n/anthy-ss/anthy-ss-4723.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/app-i18n/anthy-ss/anthy-ss-4723.ebuild b/app-i18n/anthy-ss/anthy-ss-4723.ebuild
new file mode 100644
index 000000000000..4e80ed0c9bf8
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-4723.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-4723.ebuild,v 1.1 2003/11/24 15:41:20 usata Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/6921/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}