summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-12-31 20:08:58 +0000
committerMamoru Komachi <usata@gentoo.org>2003-12-31 20:08:58 +0000
commit61385ea43d1824ad776ebe91c80c7471a8c33530 (patch)
tree7ce99117366d8b152cb697328ea84b644a319c6c /app-i18n/anthy-ss
parentNew snapshot. Added canna zipcode dictionary support. (diff)
downloadgentoo-2-61385ea43d1824ad776ebe91c80c7471a8c33530.tar.gz
gentoo-2-61385ea43d1824ad776ebe91c80c7471a8c33530.tar.bz2
gentoo-2-61385ea43d1824ad776ebe91c80c7471a8c33530.zip
New snapshot. Added canna zipcode dictionary support.
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-4901.ebuild71
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-49011
4 files changed, 80 insertions, 3 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index 4315a06dbca7..5e5c991ac537 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.10 2003/12/21 10:22:15 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.11 2003/12/31 20:08:39 usata Exp $
+
+*anthy-ss-4901 (01 Jan 2004)
+
+ 01 Jan 2004; <usata@gentoo.org> anthy-ss-4901.ebuild:
+ New snapshot. Added canna zipcode dictionary support.
*anthy-ss-4819 (21 Dec 2003)
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index fa484d2d599f..699909117c1d 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -3,9 +3,9 @@ MD5 9bf04e14dd27819240809d630b68913d anthy-ss-4703.ebuild 1521
MD5 3033ac5c3378e91a634e3918ef4f3278 anthy-ss-4723.ebuild 1521
MD5 7895ccbd6db61a9d61ca8de1a670441b anthy-ss-4819.ebuild 1521
MD5 684500740c6cbdd321c66f10db336798 anthy-ss-4809.ebuild 1521
-MD5 1c2307208f8eabed4d70bb0cc6720109 ChangeLog 1775
+MD5 e7f9855859d55deeb4eb84d93c0f1905 ChangeLog 1918
MD5 ca30b7ef075f2fc650499a1a074aa91f metadata.xml 818
-MD5 cef2563226eee5623c2e33467bda8ee3 anthy-ss-4901.ebuild 1521
+MD5 504f9d882fb3f4f6c470a35c690f56af anthy-ss-4901.ebuild 1521
MD5 431707cc13e20909d3b1600ce9b581a7 files/digest-anthy-ss-4703 63
MD5 8c24753fce14539cbe9857beb0eb6515 files/digest-anthy-ss-4708 63
MD5 3ac07bb6d11f16116dafa5e8cf462dc8 files/digest-anthy-ss-4723 63
diff --git a/app-i18n/anthy-ss/anthy-ss-4901.ebuild b/app-i18n/anthy-ss/anthy-ss-4901.ebuild
new file mode 100644
index 000000000000..9f3551bb81be
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-4901.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-4901.ebuild,v 1.1 2003/12/31 20:08:39 usata Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/7435/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-4901 b/app-i18n/anthy-ss/files/digest-anthy-ss-4901
new file mode 100644
index 000000000000..3c420c898cc3
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-4901
@@ -0,0 +1 @@
+MD5 9bc1f16ebe0c55e00914ffce4ac279c3 anthy-4901.tar.gz 1520348