summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2005-11-13 08:17:19 +0000
committerAkinori Hattori <hattya@gentoo.org>2005-11-13 08:17:19 +0000
commit283f40175ca846bd2781d9f705284ab77ada4abc (patch)
tree1084deb6c7df3f36c7e320f6c56f456c53db5712 /app-i18n/anthy/anthy-7100b.ebuild
parentnew upstream release (diff)
downloadgentoo-2-283f40175ca846bd2781d9f705284ab77ada4abc.tar.gz
gentoo-2-283f40175ca846bd2781d9f705284ab77ada4abc.tar.bz2
gentoo-2-283f40175ca846bd2781d9f705284ab77ada4abc.zip
new upstream release.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-i18n/anthy/anthy-7100b.ebuild')
-rw-r--r--app-i18n/anthy/anthy-7100b.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-i18n/anthy/anthy-7100b.ebuild b/app-i18n/anthy/anthy-7100b.ebuild
new file mode 100644
index 000000000000..d99c4a9b9f12
--- /dev/null
+++ b/app-i18n/anthy/anthy-7100b.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-7100b.ebuild,v 1.1 2005/11/13 08:13:18 hattya Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs ucs4"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/17231/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy-ss"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake -j1 || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ rm doc/Makefile*
+
+ dodoc AUTHORS COPYING DIARY INSTALL NEWS README ChangeLog
+ dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}