summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-10 00:04:50 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-10 00:04:50 +0000
commit01009dfb2808545581e9ca91fe60bba3ef3c0f15 (patch)
tree3e87ba2b0aa91c1cbf21e476942bd9ad3b7355d7 /app-i18n/anthy
parentVersion bump. (diff)
downloadgentoo-2-01009dfb2808545581e9ca91fe60bba3ef3c0f15.tar.gz
gentoo-2-01009dfb2808545581e9ca91fe60bba3ef3c0f15.tar.bz2
gentoo-2-01009dfb2808545581e9ca91fe60bba3ef3c0f15.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/ChangeLog7
-rw-r--r--app-i18n/anthy/anthy-9100h.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 99548cf87ae5..86dd0447d69f 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.120 2009/01/29 15:12:01 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.121 2009/02/10 00:04:50 matsuu Exp $
+
+*anthy-9100h (10 Feb 2009)
+
+ 10 Feb 2009; MATSUU Takuto <matsuu@gentoo.org> +anthy-9100h.ebuild:
+ Version bumped.
*anthy-9100g (29 Jan 2009)
diff --git a/app-i18n/anthy/anthy-9100h.ebuild b/app-i18n/anthy/anthy-9100h.ebuild
new file mode 100644
index 000000000000..5fd1d3dd33c0
--- /dev/null
+++ b/app-i18n/anthy/anthy-9100h.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-9100h.ebuild,v 1.1 2009/02/10 00:04:50 matsuu Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/37536/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+DEPEND="!app-i18n/anthy-ss
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ sed -i \
+ -e "/set_input_encoding eucjp/aread /var/lib/canna/dic/canna/nichan.ctd" \
+ mkworddic/dict.args.in || die
+ fi
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use emacs || myconf="EMACS=no"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+ dodoc AUTHORS DIARY NEWS README ChangeLog
+
+ docinto doc
+ rm doc/Makefile*
+ dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}