summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-07-17 07:42:27 +0000
committerNaohiro Aota <naota@gentoo.org>2011-07-17 07:42:27 +0000
commit603175c68adb1521c5b3f8147ca1a1e4ae342e2d (patch)
tree42bac46094f16ef00d173ccbdd40a93490ebb4c0 /app-i18n/kimera/kimera-2.11-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-603175c68adb1521c5b3f8147ca1a1e4ae342e2d.tar.gz
gentoo-2-603175c68adb1521c5b3f8147ca1a1e4ae342e2d.tar.bz2
gentoo-2-603175c68adb1521c5b3f8147ca1a1e4ae342e2d.zip
Fix underlinking. bug #369557
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/kimera/kimera-2.11-r1.ebuild')
-rw-r--r--app-i18n/kimera/kimera-2.11-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/kimera/kimera-2.11-r1.ebuild b/app-i18n/kimera/kimera-2.11-r1.ebuild
new file mode 100644
index 000000000000..65f638e9d8a0
--- /dev/null
+++ b/app-i18n/kimera/kimera-2.11-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/kimera-2.11-r1.ebuild,v 1.1 2011/07/17 07:42:26 naota Exp $
+
+EAPI=3
+inherit qt4-r2 eutils
+
+DESCRIPTION="A Japanese input method which supports the XIM protocol"
+SRC_URI="mirror://sourceforge.jp/kimera/37271/${P}.tar.gz"
+HOMEPAGE="http://kimera.sourceforge.jp/"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+anthy"
+
+DEPEND="x11-libs/qt-core:4
+ anthy? ( app-i18n/anthy )
+ !anthy? ( app-i18n/canna )"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README*"
+
+src_configure() {
+ local myconf="target.path=/usr/$(get_libdir)/${P}"
+ use anthy || myconf="${myconf} no_anthy=1"
+ eqmake4 kimera.pro ${myconf}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+}