summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-04-11 22:43:30 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-04-11 22:43:30 +0000
commitbcd23f287ed21e3f408524f89df38320e42b0c3c (patch)
treea0c01c9fbdd0843fec64e122f39b3d96a1988a51 /app-i18n/nkf/nkf-2.0.5.ebuild
parentversion bump (diff)
downloadgentoo-2-bcd23f287ed21e3f408524f89df38320e42b0c3c.tar.gz
gentoo-2-bcd23f287ed21e3f408524f89df38320e42b0c3c.tar.bz2
gentoo-2-bcd23f287ed21e3f408524f89df38320e42b0c3c.zip
Version bumped.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-i18n/nkf/nkf-2.0.5.ebuild')
-rw-r--r--app-i18n/nkf/nkf-2.0.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-i18n/nkf/nkf-2.0.5.ebuild b/app-i18n/nkf/nkf-2.0.5.ebuild
new file mode 100644
index 000000000000..adbdae0901ee
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.5.ebuild,v 1.1 2005/04/11 22:43:30 matsuu Exp $
+
+inherit gcc perl-module
+
+MY_P="${PN}${PV//./}"
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="http://www01.tcp-ip.or.jp/~furukawa/nkf_utf8/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64 ~ia64"
+IUSE="perl cjk"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" nkf || die
+ if use perl; then
+ cd ${S}/NKF.mod
+ perl-module_src_compile
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+ if use cjk; then
+ dodir /usr/share/man/ja/man1
+ insinto /usr/share/man/ja/man1
+ ./nkf -e nkf.1j > nkf.1
+ doins nkf.1
+ fi
+ dodoc INSTALL* nkf.doc
+ if use perl; then
+ cd ${S}/NKF.mod
+ perl-module_src_install
+ fi
+}