summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-08 14:58:29 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-08 14:58:29 +0000
commit3be8311ef85f32ce45a44a4e1591813649747b64 (patch)
treeeceeaf947fc9fa2e600dab0cb0ebcef7cc8826c7 /app-i18n/nkf
parentVersion bump. (diff)
downloadgentoo-2-3be8311ef85f32ce45a44a4e1591813649747b64.tar.gz
gentoo-2-3be8311ef85f32ce45a44a4e1591813649747b64.tar.bz2
gentoo-2-3be8311ef85f32ce45a44a4e1591813649747b64.zip
Fixed pre-strip, bug #248725. Clean up.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/ChangeLog9
-rw-r--r--app-i18n/nkf/nkf-2.0.7-r1.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index 43e231cf1bfe..6b363ced4757 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/nkf
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.43 2007/09/17 14:36:57 hattya Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.44 2008/12/08 14:58:29 matsuu Exp $
+
+*nkf-2.0.7-r1 (08 Dec 2008)
+
+ 08 Dec 2008; MATSUU Takuto <matsuu@gentoo.org> +nkf-2.0.7-r1.ebuild:
+ Fixed pre-strip, bug #248725. Clean up.
17 Sep 2007; Akinori Hattori <hattya@gentoo.org> -files/nkf-python.patch,
-nkf-2.0.4.ebuild, -nkf-2.0.5-r1.ebuild, -nkf-2.0.7_beta1.ebuild:
diff --git a/app-i18n/nkf/nkf-2.0.7-r1.ebuild b/app-i18n/nkf/nkf-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..70979474c4d7
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.0.7-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7-r1.ebuild,v 1.1 2008/12/08 14:58:29 matsuu Exp $
+
+inherit toolchain-funcs eutils perl-module distutils
+
+MY_P="nkf${PV//./}"
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="mirror://sourceforge.jp/nkf/20770/${MY_P}.tar.gz
+ python? ( http://city.plala.jp/download/nkf/NKF_python.tgz )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="perl python linguas_ja"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+
+ sed -i -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' Makefile || die
+
+ if use python; then
+ unpack NKF_python.tgz
+ # bug #248725
+ sed -i -e "s/-s/${CFLAGS}/" NKF.python/setup.py || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" nkf || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_compile
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_compile
+ fi
+}
+
+src_test() {
+ emake test || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+ if use linguas_ja; then
+ ./nkf -e nkf.1j > nkf.1
+ doman -i18n=ja nkf.1
+ fi
+ dodoc nkf.doc
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_install
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_install
+ fi
+}