summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-01-06 04:02:09 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-01-06 04:02:09 +0000
commitb260575532f109600e2c083bd033d71a5f797e26 (patch)
tree08fb023bd9592db66544b59b12cd93cb0ad296aa /app-i18n/nkf
parentQA: Removed unused versions. (diff)
downloadgentoo-2-b260575532f109600e2c083bd033d71a5f797e26.tar.gz
gentoo-2-b260575532f109600e2c083bd033d71a5f797e26.tar.bz2
gentoo-2-b260575532f109600e2c083bd033d71a5f797e26.zip
Version bumped.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/ChangeLog9
-rw-r--r--app-i18n/nkf/files/digest-nkf-2.0.76
-rw-r--r--app-i18n/nkf/nkf-2.0.7.ebuild61
3 files changed, 74 insertions, 2 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index 1c1afed7a719..e18ddc1c9841 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/nkf
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.34 2006/12/20 23:24:23 flameeyes Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.35 2007/01/06 04:02:09 matsuu Exp $
+
+*nkf-2.0.7 (06 Jan 2007)
+
+ 06 Jan 2007; MATSUU Takuto <matsuu@gentoo.org> +nkf-2.0.7.ebuild:
+ Version bumped.
20 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> nkf-2.0.7_beta1.ebuild:
Quote ${S} uses, replace cjk useflag with linguas_ja, use doman to install
diff --git a/app-i18n/nkf/files/digest-nkf-2.0.7 b/app-i18n/nkf/files/digest-nkf-2.0.7
new file mode 100644
index 000000000000..6b4568a5db98
--- /dev/null
+++ b/app-i18n/nkf/files/digest-nkf-2.0.7
@@ -0,0 +1,6 @@
+MD5 87d43ac572d2036b9da1b0d9c79cebdc NKF_python.tgz 2242
+RMD160 759979ff4ade90b409439e7038f21a88bb14e46b NKF_python.tgz 2242
+SHA256 4dcf34edbd5baf5aabd9e0cd439ca342a99b92c6748311ab693e9277d40d552b NKF_python.tgz 2242
+MD5 af11dcd3fe71d67831c020e3bfd5073b nkf207.tar.gz 150501
+RMD160 da6eebf7dd59d934eca40f2f6588e97078c8d68a nkf207.tar.gz 150501
+SHA256 71d2ba992df209a00bb1dca45e3336729dc16e51b71526bd20f897cc6127a275 nkf207.tar.gz 150501
diff --git a/app-i18n/nkf/nkf-2.0.7.ebuild b/app-i18n/nkf/nkf-2.0.7.ebuild
new file mode 100644
index 000000000000..555a60dfcdb2
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.0.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7.ebuild,v 1.1 2007/01/06 04:02:09 matsuu Exp $
+
+inherit toolchain-funcs eutils perl-app distutils
+
+MY_P="nkf${PV//./}"
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="mirror://sourceforge.jp/nkf/20770/${MY_P}.tar.gz
+ python? ( http://city.plala.jp/download/nkf/NKF_python.tgz )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="perl python linguas_ja"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+
+ sed -i -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' Makefile || die
+
+ if use python; then
+ unpack NKF_python.tgz
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" nkf || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_compile
+ perl-module_src_test
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_compile
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+ if use linguas_ja; then
+ ./nkf -e nkf.1j > nkf.1
+ doman -i18n=ja nkf.1
+ fi
+ dodoc INSTALL* nkf.doc
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_install
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_install
+ fi
+}