summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-18 16:54:10 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-18 16:54:10 +0000
commit3556343d9962c1d62aab61ba47b9486dfcf1b317 (patch)
treee1d418cf50f68206cfb73933352a3896d2810efd /app-i18n/scim-bridge
parentStable on ppc wrt bug 240646 (diff)
downloadgentoo-2-3556343d9962c1d62aab61ba47b9486dfcf1b317.tar.gz
gentoo-2-3556343d9962c1d62aab61ba47b9486dfcf1b317.tar.bz2
gentoo-2-3556343d9962c1d62aab61ba47b9486dfcf1b317.zip
Fixed intltool issue, bug #241954.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-i18n/scim-bridge')
-rw-r--r--app-i18n/scim-bridge/ChangeLog8
-rw-r--r--app-i18n/scim-bridge/scim-bridge-0.4.15-r2.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/app-i18n/scim-bridge/ChangeLog b/app-i18n/scim-bridge/ChangeLog
index aa1e6f1a6e3b..d451a85c541b 100644
--- a/app-i18n/scim-bridge/ChangeLog
+++ b/app-i18n/scim-bridge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/scim-bridge
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-bridge/ChangeLog,v 1.21 2008/07/27 19:51:51 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-bridge/ChangeLog,v 1.22 2008/10/18 16:54:10 matsuu Exp $
+
+*scim-bridge-0.4.15-r2 (18 Oct 2008)
+
+ 18 Oct 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +scim-bridge-0.4.15-r2.ebuild:
+ Fixed intltool issue, bug #241954.
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> scim-bridge-0.4.9.ebuild,
scim-bridge-0.4.15-r1.ebuild:
diff --git a/app-i18n/scim-bridge/scim-bridge-0.4.15-r2.ebuild b/app-i18n/scim-bridge/scim-bridge-0.4.15-r2.ebuild
new file mode 100644
index 000000000000..dcb0699105ef
--- /dev/null
+++ b/app-i18n/scim-bridge/scim-bridge-0.4.15-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-bridge/scim-bridge-0.4.15-r2.ebuild,v 1.1 2008/10/18 16:54:10 matsuu Exp $
+
+EAPI="1"
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit autotools eutils qt3
+
+DESCRIPTION="Yet another IM-client of SCIM"
+HOMEPAGE="http://www.scim-im.org/projects/scim_bridge"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="doc gtk qt3 qt4"
+
+RESTRICT="test"
+
+RDEPEND=">=app-i18n/scim-1.4.6
+ gtk? (
+ >=x11-libs/gtk+-2.2
+ >=x11-libs/pango-1.1
+ )
+ qt3? (
+ x11-libs/qt:3
+ >=x11-libs/pango-1.1
+ )
+ qt4? (
+ || ( ( x11-libs/qt-gui:4 x11-libs/qt-core:4 )
+ =x11-libs/qt-4.3*:4 )
+ >=x11-libs/pango-1.1
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ doc? ( app-doc/doxygen )"
+
+get_gtk_confdir() {
+ if use amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && use x86 ) ; then
+ echo "/etc/gtk-2.0/${CHOST}"
+ else
+ echo "/etc/gtk-2.0"
+ fi
+}
+
+pkg_setup() {
+ if use qt3 && ! built_with_use =x11-libs/qt-3* immqt-bc && ! built_with_use =x11-libs/qt-3* immqt; then
+ die "You need to rebuild >=x11-libs/qt-3.3.4 with immqt-bc(recommended) or immqt USE flag enabled."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.4.14-qt4.patch
+ # bug #241954
+ intltoolize --force
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable gtk gtk2-immodule) \
+ $(use_enable qt3 qt3-immodule) \
+ $(use_enable qt4 qt4-immodule) \
+ $(use_enable doc documents) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog
+ elog "If you would like to use ${PN} as default instead of scim, set"
+ elog " $ export GTK_IM_MODULE=scim-bridge"
+ elog " $ export QT_IM_MODULE=scim-bridge"
+ elog
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
+}
+
+pkg_postrm() {
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
+}