summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-13 13:33:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-13 13:33:28 +0000
commit6a5af16cd8beb95d3bec9b097b3e633e5f6c8d1a (patch)
tree5020ae6285b71912a16543768e9417e89fbcad46 /app-i18n
parentInitial import. (diff)
downloadgentoo-2-6a5af16cd8beb95d3bec9b097b3e633e5f6c8d1a.tar.gz
gentoo-2-6a5af16cd8beb95d3bec9b097b3e633e5f6c8d1a.tar.bz2
gentoo-2-6a5af16cd8beb95d3bec9b097b3e633e5f6c8d1a.zip
Version bumped.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-skk/ChangeLog9
-rw-r--r--app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-i18n/ibus-skk/ChangeLog b/app-i18n/ibus-skk/ChangeLog
index 751a5a2f0ab2..4d6bbc2c7c77 100644
--- a/app-i18n/ibus-skk/ChangeLog
+++ b/app-i18n/ibus-skk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-skk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.3 2009/12/31 06:20:58 matsuu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.4 2010/01/13 13:33:28 matsuu Exp $
+
+*ibus-skk-0.0.4 (13 Jan 2010)
+
+ 13 Jan 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-skk-0.0.4.ebuild:
+ Version bumped.
*ibus-skk-0.0.3 (31 Dec 2009)
diff --git a/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild b/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild
new file mode 100644
index 000000000000..372ab4982cc4
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild,v 1.1 2010/01/13 13:33:28 matsuu Exp $
+
+EAPI="2"
+
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}