summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-10-17 10:12:11 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-10-17 10:12:11 +0000
commit8a44c1110cda1f0df0806f789dcc560cd5989d9e (patch)
tree8bc986f3743f8fac616485c4df77326524bb4f8e /app-i18n
parentstable on x86 (Manifest recommit) (diff)
downloadgentoo-2-8a44c1110cda1f0df0806f789dcc560cd5989d9e.tar.gz
gentoo-2-8a44c1110cda1f0df0806f789dcc560cd5989d9e.tar.bz2
gentoo-2-8a44c1110cda1f0df0806f789dcc560cd5989d9e.zip
version bump
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest2
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5812.ebuild68
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-58121
4 files changed, 77 insertions, 1 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index 346839d3c1d9..0dd909ce1c76 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.49 2004/09/15 11:44:40 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.50 2004/10/17 10:12:11 hattya Exp $
+
+*anthy-ss-5812 (17 Oct 2004)
+
+ 17 Oct 2004; Akinori Hattori <hattya@gentoo.org> +anthy-ss-5812.ebuild:
+ version bump.
15 Sep 2004; Akinori Hattori <hattya@gentoo.org> -anthy-ss-5701.ebuild:
this version has a bug.
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 30687df9cf3a..a54665635e69 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -3,9 +3,11 @@ MD5 685ca99e1830c1c18ef9dcd474aeb690 anthy-ss-5608.ebuild 1516
MD5 9450455211862e1d4be31f74762bc806 anthy-ss-5613.ebuild 1516
MD5 1b87ce8d9b1c27f4da17078b6090deb4 anthy-ss-5626.ebuild 1516
MD5 59e16299aff2e60834b8f74767855f38 anthy-ss-5714.ebuild 1516
+MD5 49e4d93c5dd2e5893a2d3863f0f86c1f anthy-ss-5812.ebuild 1396
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 5d67456010e53e1c3ac13fbb21bc43cd files/digest-anthy-ss-5608 63
MD5 4f29f88aefb078e637262bb3574ebdde files/digest-anthy-ss-5613 63
MD5 b138cf04ba4c5ff57d888a4bd92828da files/digest-anthy-ss-5626 63
MD5 c46e2a82231884e714d609923e5ee847 files/digest-anthy-ss-5714 63
+MD5 9816cbc863f4e0880da1f19aebca4f67 files/digest-anthy-ss-5812 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5812.ebuild b/app-i18n/anthy-ss/anthy-ss-5812.ebuild
new file mode 100644
index 000000000000..e556c0653efd
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5812.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5812.ebuild,v 1.1 2004/10/17 10:12:11 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/11845/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5812 b/app-i18n/anthy-ss/files/digest-anthy-ss-5812
new file mode 100644
index 000000000000..2989c8562268
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5812
@@ -0,0 +1 @@
+MD5 baa262578640909bf167f837a1d38bb2 anthy-5812.tar.gz 1553775