summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-09-26 19:54:27 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-09-26 19:54:27 +0000
commitec92c6a287de0be890c7f59b97355491885b3160 (patch)
tree8f17658f0aaf104aa37de65d15e912f78551be30 /app-i18n
parentdropping file temporarily to adjust sticky options (diff)
downloadgentoo-2-ec92c6a287de0be890c7f59b97355491885b3160.tar.gz
gentoo-2-ec92c6a287de0be890c7f59b97355491885b3160.tar.bz2
gentoo-2-ec92c6a287de0be890c7f59b97355491885b3160.zip
fixed cvs sticky options on file(s) that should not have cvs keyword expansion
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/skk-jisyo/ChangeLog8
-rw-r--r--app-i18n/skk-jisyo/files/unannotation.awk75
2 files changed, 81 insertions, 2 deletions
diff --git a/app-i18n/skk-jisyo/ChangeLog b/app-i18n/skk-jisyo/ChangeLog
index a712cd4f4000..250141ffbd53 100644
--- a/app-i18n/skk-jisyo/ChangeLog
+++ b/app-i18n/skk-jisyo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/skk-jisyo
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/skk-jisyo/ChangeLog,v 1.65 2013/02/12 09:36:15 naota Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skk-jisyo/ChangeLog,v 1.66 2014/09/26 19:54:27 axs Exp $
+
+ 26 Sep 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +files/unannotation.awk:
+ fixed cvs sticky options on file(s) that should not have cvs keyword expansion
12 Feb 2013; Naohiro Aota <naota@gentoo.org> skk-jisyo-200705.ebuild,
skk-jisyo-200812.ebuild, skk-jisyo-201101.ebuild, skk-jisyo-9999.ebuild:
diff --git a/app-i18n/skk-jisyo/files/unannotation.awk b/app-i18n/skk-jisyo/files/unannotation.awk
new file mode 100644
index 000000000000..88d9eb254344
--- /dev/null
+++ b/app-i18n/skk-jisyo/files/unannotation.awk
@@ -0,0 +1,75 @@
+# unannotation.awk: filter to remove annotations in dictionaries.
+#
+# Copyright (C) 2001, 2002 SKK Development Team <skk@ring.gr.jp>
+#
+# Maintainer: SKK Development Team <skk@ring.gr.jp>
+# Version: $Id: unannotation.awk,v 1.3 2006/01/04 10:35:06 skk-cvs Exp $
+# Last Modified: $Date: 2006/01/04 10:35:06 $
+#
+# This file is part of Daredevil SKK.
+#
+# Daredevil SKK is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or
+# (at your option) any later version.
+#
+# Daredevil SKK is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Daredevil SKK, see the file COPYING. If not, write to
+# the Free Software Foundation Inc., 51 Franklin St, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+BEGIN{
+ print ";; -*- text -*-";
+ ctime = myctime(0);
+ this = ARGV[1];
+ if (match(this, /\.annotated$/) != 0){
+ this = substr(this, 1, RSTART - 1);
+ } else
+ this = this ".unannotated";
+ printf(";; %s was generated automatically by unannotation.awk at %s\n",
+ this, ctime);
+ #getline modeindicator
+ #if (match(modeindicator, /;; -*- text -*-/) != 0){
+ # print modeindicator;
+ #}
+}
+#$0 !~ /"^;; -\*- text -\*-\n"/{
+{
+ if (match($0, /^;/) == 0) {
+ gsub(";[^/]*/", "/");
+ if (DEQUOTE && $0 ~ /\\073/) {
+ $0 = dequote($0);
+ }
+ }
+ print;
+}
+function myctime(ts, format) {
+ format = "%a %b %e %H:%M:%S %Y";
+ if (ts == 0)
+ ts = systime(); # use current time as default
+ return strftime(format, ts);
+}
+# convert '\073' to ';' and strip '(concat "...")'.
+# example: 'smile /(concat "^_^\073\073")/:-)/' to 'smile /^_^;;/:-)/'
+# @param s string to convert
+# @return converted string
+function dequote(s) {
+ ret = "";
+ n = split(s, a, "/");
+ for (i = 1; i < n; i++) {
+ if (a[i] ~ /^\(concat ".*\\073.*"\)$/) { # \073 = ';'
+ gsub(/\\073/, ";", a[i]);
+ if (a[i] !~ /\\/) { # no other quote
+ a[i] = gensub(/^\(concat "(.*)"\)$/, "\\1", "g", a[i]);
+ }
+ }
+ ret = ret a[i] "/";
+ }
+ return ret;
+}
+# end of unannotation.awk.