summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-08-14 20:54:41 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-08-14 20:54:41 +0000
commit54cd2af3fe91fad034695ec66725f6d0be704156 (patch)
treef2cbaa9719a92bb3487ad08cf9d89fedc69f0c0e /app-laptop
parentStable on amd64 wrt bug #188796 (diff)
downloadgentoo-2-54cd2af3fe91fad034695ec66725f6d0be704156.tar.gz
gentoo-2-54cd2af3fe91fad034695ec66725f6d0be704156.tar.bz2
gentoo-2-54cd2af3fe91fad034695ec66725f6d0be704156.zip
Added a --missing false since not all versions of pciutils support the zlib USE flag. This was reported to bug #188221 by Åsmund Grammeltvedt <asmundg@big-oil.org>.
(Portage version: 2.1.3.3)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/smcinit/ChangeLog7
-rw-r--r--app-laptop/smcinit/smcinit-0.4.ebuild4
2 files changed, 8 insertions, 3 deletions
diff --git a/app-laptop/smcinit/ChangeLog b/app-laptop/smcinit/ChangeLog
index f8186b6e561d..2c3c64b1e50e 100644
--- a/app-laptop/smcinit/ChangeLog
+++ b/app-laptop/smcinit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/smcinit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/ChangeLog,v 1.7 2007/06/22 18:14:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/ChangeLog,v 1.8 2007/08/14 20:54:41 wolf31o2 Exp $
+
+ 14 Aug 2007; Chris Gianelloni <wolf31o2@gentoo.org> smcinit-0.4.ebuild:
+ Added a --missing false since not all versions of pciutils support the zlib
+ USE flag. This was reported to bug #188221 by Åsmund Grammeltvedt
+ <asmundg@big-oil.org>.
22 Jun 2007; Chris Gianelloni <wolf31o2@gentoo.org> smcinit-0.4.ebuild:
I forgot to add the DEPEND on sys-libs/zlib.
diff --git a/app-laptop/smcinit/smcinit-0.4.ebuild b/app-laptop/smcinit/smcinit-0.4.ebuild
index d9e2636a2b8c..a5d237c4d629 100644
--- a/app-laptop/smcinit/smcinit-0.4.ebuild
+++ b/app-laptop/smcinit/smcinit-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/smcinit-0.4.ebuild,v 1.7 2007/06/22 18:14:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/smcinit-0.4.ebuild,v 1.8 2007/08/14 20:54:41 wolf31o2 Exp $
inherit eutils
@@ -35,7 +35,7 @@ src_compile()
if use zlib
then
LIBS="-lpci -lz"
- elif built_with_use sys-apps/pciutils zlib
+ elif built_with_use --missing false sys-apps/pciutils zlib
then
die "You need to build with USE=zlib to match sys-apps/pcituils"
fi