summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-02-15 18:11:41 +0000
committerPacho Ramos <pacho@gentoo.org>2013-02-15 18:11:41 +0000
commita5b89aa0437f1e1d9337aa2cfd9df9a916120289 (patch)
tree3227036ed659883b32515965261d6bfef2ed84a9 /app-laptop
parentStable for amd64, wrt bug #455380 (diff)
downloadgentoo-2-a5b89aa0437f1e1d9337aa2cfd9df9a916120289.tar.gz
gentoo-2-a5b89aa0437f1e1d9337aa2cfd9df9a916120289.tar.bz2
gentoo-2-a5b89aa0437f1e1d9337aa2cfd9df9a916120289.zip
Don't show elog messages always (#457596)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/configure-trackpoint/ChangeLog8
-rw-r--r--app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild24
2 files changed, 18 insertions, 14 deletions
diff --git a/app-laptop/configure-trackpoint/ChangeLog b/app-laptop/configure-trackpoint/ChangeLog
index 3505a1040d2f..65ba4abedc4d 100644
--- a/app-laptop/configure-trackpoint/ChangeLog
+++ b/app-laptop/configure-trackpoint/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-laptop/configure-trackpoint
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/configure-trackpoint/ChangeLog,v 1.5 2012/05/02 20:22:39 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/configure-trackpoint/ChangeLog,v 1.6 2013/02/15 18:11:41 pacho Exp $
+
+ 15 Feb 2013; Pacho Ramos <pacho@gentoo.org> configure-trackpoint-0.7.ebuild:
+ Don't show elog messages always (#457596)
02 May 2012; Jeff Horelick <jdhore@gentoo.org>
configure-trackpoint-0.7.ebuild:
@@ -23,4 +26,3 @@
+configure-trackpoint-0.7.ebuild, +metadata.xml:
Initial commit of configure-trackpoint, a configuration utility for
app-laptop/tp_smapi
-
diff --git a/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild b/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild
index a7ea81e8f2b2..20dfac727405 100644
--- a/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild
+++ b/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild,v 1.3 2012/05/02 20:22:39 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild,v 1.4 2013/02/15 18:11:41 pacho Exp $
-EAPI=2
-inherit gnome2
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
DESCRIPTION="Thinkpad GNOME configuration utility for TrackPoint (For the linux
kernel 2.6 TrackPoint driver)"
@@ -24,6 +26,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
+ DOC_CONTENTS="The ${PN} does not automatically load the app-laptop/tp_smapi modules
+ so you need to do it manually"
+
if has_version kde-base/kdesu && ! has_version x11-libs/gksu; then
sed -i -e "/^Exec/s:gksu:kdesu:" ${PN}.desktop \
|| die "Failed to replace gksu with kdesu"
@@ -31,15 +36,12 @@ src_prepare() {
gnome2_src_prepare
}
-src_configure() {
- G2CONF="--disable-dependency-tracking --disable-maintainer-mode"
- gnome2_src_configure
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
}
pkg_postinst() {
gnome2_pkg_postinst
- elog
- elog "The ${PN} does not automatically load the app-laptop/tp_smapi modules"
- elog "so you need to do it manually"
- elog
+ readme.gentoo_print_elog
}