summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-25 11:10:59 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-25 11:10:59 +0000
commit9c5bbabb1d8e44b8d0c5d907804dbdc5f69f8d54 (patch)
treedf7368368b1ceb756177d45ec57a19082bda9f45 /app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
parentUpdate git URI stripping for gnome.org. (diff)
downloadgentoo-2-9c5bbabb1d8e44b8d0c5d907804dbdc5f69f8d54.tar.gz
gentoo-2-9c5bbabb1d8e44b8d0c5d907804dbdc5f69f8d54.tar.bz2
gentoo-2-9c5bbabb1d8e44b8d0c5d907804dbdc5f69f8d54.zip
Add USE-flag and dependency for Twitter plugin, minor dependency corrections, thanks to 0xd34df00d
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft/lc-azoth/lc-azoth-9999.ebuild')
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
index 8791088eb702..f0bc7b23fb0a 100644
--- a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
+++ b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild,v 1.7 2013/09/24 18:10:49 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild,v 1.8 2013/09/25 11:10:59 pinkbyte Exp $
EAPI="5"
@@ -13,7 +13,7 @@ KEYWORDS=""
IUSE="debug doc astrality +acetamide +adiumstyles +autoidler +autopaste +birthdaynotifier
+chathistory +crypt +depester +embedmedia +herbicide +hili +isterique
+juick +keeso +lastseen +metacontacts media +msn +murm +latex +nativeemoticons
- +otroid +p100q +spell shx +standardstyles +vader +xmpp +xtazy"
+ +otroid +p100q +spell shx +standardstyles +vader +woodpecker +xmpp +xtazy"
COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
dev-libs/qjson
@@ -24,9 +24,13 @@ COMMON_DEPEND="~app-leechcraft/lc-core-${PV}
media? ( dev-qt/qtmultimedia:4 )
msn? ( net-libs/libmsn )
spell? ( app-text/hunspell )
- xmpp? ( =net-libs/qxmpp-9999 media-libs/speex )
+ woodpecker? ( dev-libs/kqoauth )
+ xmpp? (
+ =net-libs/qxmpp-9999
+ media? ( =net-libs/qxmpp-9999[speex] )
+ )
xtazy? (
- app-leechcraft/lc-xtazy
+ ~app-leechcraft/lc-xtazy-${PV}
dev-qt/qtdbus:4
)
crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
@@ -78,6 +82,7 @@ src_configure() {
$(cmake-utils_use_enable shx AZOTH_SHX)
$(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
$(cmake-utils_use_enable vader AZOTH_VADER)
+ $(cmake-utils_use_enable woodpecker AZOTH_WOODPECKER)
$(cmake-utils_use_enable xmpp AZOTH_XOOX)
$(cmake-utils_use_enable xtazy AZOTH_XTAZY)
)