summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-07-03 15:56:40 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-07-03 15:56:40 +0000
commit577971c3a56acfb660a9da68055ea8e227b2af6f (patch)
treece51019265fc32ecf92966080ab8c25cf33ea691 /app-leechcraft/lc-core
parentBump LeechCraft to 0.5.98, thanks to 0xd34df00d. (diff)
downloadgentoo-2-577971c3a56acfb660a9da68055ea8e227b2af6f.tar.gz
gentoo-2-577971c3a56acfb660a9da68055ea8e227b2af6f.tar.bz2
gentoo-2-577971c3a56acfb660a9da68055ea8e227b2af6f.zip
Bump LeechCraft to 0.5.98, thanks to 0xd34df00d.
(Portage version: 2.1.12.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-core')
-rw-r--r--app-leechcraft/lc-core/ChangeLog7
-rw-r--r--app-leechcraft/lc-core/lc-core-0.5.98.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-leechcraft/lc-core/ChangeLog b/app-leechcraft/lc-core/ChangeLog
index b8d215a5ed13..11d29dd4b09d 100644
--- a/app-leechcraft/lc-core/ChangeLog
+++ b/app-leechcraft/lc-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.7 2013/06/11 17:16:27 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.8 2013/07/03 15:56:40 maksbotan Exp $
+
+*lc-core-0.5.98 (03 Jul 2013)
+
+ 03 Jul 2013; Maxim Koltsov <maksbotan@gentoo.org> +lc-core-0.5.98.ebuild:
+ Bump LeechCraft to 0.5.98, thanks to 0xd34df00d.
*lc-core-0.5.97 (11 Jun 2013)
diff --git a/app-leechcraft/lc-core/lc-core-0.5.98.ebuild b/app-leechcraft/lc-core/lc-core-0.5.98.ebuild
new file mode 100644
index 000000000000..e6b57db4dcc3
--- /dev/null
+++ b/app-leechcraft/lc-core/lc-core-0.5.98.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/lc-core-0.5.98.ebuild,v 1.1 2013/07/03 15:56:40 maksbotan Exp $
+
+EAPI="5"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit eutils confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc +sqlite postgres"
+
+COMMON_DEPEND=">=dev-libs/boost-1.46
+ dev-qt/qtcore:4
+ dev-qt/qtdeclarative:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4[postgres?,sqlite?]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtsvg:4
+ || (
+ kde-base/oxygen-icons
+ x11-themes/kfaenza
+ )"
+
+REQUIRED_USE="|| ( postgres sqlite )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_PLUGINS=False
+ $(cmake-utils_use_with doc DOCS)
+ )
+ if [[ ${PV} != 9999 ]]; then
+ mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}/${PN#lc-}"/out/html/*
+}