summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-07-03 16:09:19 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-07-03 16:09:19 +0000
commit3c3367de13ee5782662988905de533fffcd66fe8 (patch)
treefc43503d12ed042adc73ff62e190795840fc0cb0 /app-leechcraft
parentBump LeechCraft to 0.5.98, thanks to 0xd34df00d. (diff)
downloadgentoo-2-3c3367de13ee5782662988905de533fffcd66fe8.tar.gz
gentoo-2-3c3367de13ee5782662988905de533fffcd66fe8.tar.bz2
gentoo-2-3c3367de13ee5782662988905de533fffcd66fe8.zip
Bump LeechCraft to 0.5.98, thanks to 0xd34df00d.
(Portage version: 2.1.12.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog7
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.5.98.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index fb9044ab4657..414003b94115 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.5 2013/06/11 17:32:13 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.6 2013/07/03 16:09:19 maksbotan Exp $
+
+*lc-monocle-0.5.98 (03 Jul 2013)
+
+ 03 Jul 2013; Maxim Koltsov <maksbotan@gentoo.org> +lc-monocle-0.5.98.ebuild:
+ Bump LeechCraft to 0.5.98, thanks to 0xd34df00d.
*lc-monocle-0.5.97 (11 Jun 2013)
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.5.98.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.5.98.ebuild
new file mode 100644
index 000000000000..3fdb9ac191c6
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.5.98.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.5.98.ebuild,v 1.1 2013/07/03 16:09:19 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? ( app-text/libspectre )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}