summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-04-14 16:18:51 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-04-14 16:18:51 +0000
commitb36a5b286eab92fb11b5b24f12ec230ed1ff5f91 (patch)
tree9de6167a69b348bdda2de60562fd233af6068883 /app-leechcraft
parentStable for ppc, wrt bug #463108 (diff)
downloadgentoo-2-b36a5b286eab92fb11b5b24f12ec230ed1ff5f91.tar.gz
gentoo-2-b36a5b286eab92fb11b5b24f12ec230ed1ff5f91.tar.bz2
gentoo-2-b36a5b286eab92fb11b5b24f12ec230ed1ff5f91.zip
Bump EAPI to 5, add documentation building and installing, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog6
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild28
2 files changed, 22 insertions, 12 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index 1109362354b6..fa03bd9cf02a 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.1 2013/03/08 22:02:32 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.2 2013/04/14 16:18:51 pinkbyte Exp $
+
+ 14 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> lc-monocle-9999.ebuild:
+ Bump EAPI to 5, add documentation building and installing, thanks to
+ 0xd34df00d
*lc-monocle-9999 (08 Mar 2013)
*lc-monocle-0.5.90-r1 (08 Mar 2013)
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
index 68ae5b2eaa10..0c0581fb2791 100644
--- a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -1,30 +1,36 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild,v 1.1 2013/03/08 22:02:32 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild,v 1.2 2013/04/14 16:18:51 pinkbyte Exp $
-EAPI="4"
+EAPI="5"
inherit leechcraft
-DESCRIPTION="Monocle, the modular document viewer for LeechCraft."
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="+djvu debug +fb2 +pdf +spectre"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
-DEPEND="~app-leechcraft/lc-core-${PV}
+RDEPEND="~app-leechcraft/lc-core-${PV}
pdf? ( app-text/poppler[qt4] )
djvu? ( app-text/djvu )
- spectre? ( app-text/libspectre )
-"
-RDEPEND="${DEPEND}"
+ spectre? ( app-text/libspectre )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
src_configure() {
- local mycmakeargs="
+ local mycmakeargs=(
$(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
$(cmake-utils_use_enable fb2 MONOCLE_FXB)
$(cmake-utils_use_enable pdf MONOCLE_PDF)
- $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)"
-
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
cmake-utils_src_configure
}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}